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Getting Started

What Is DOS Shell?

DOS Shell is a graphic extension of the Microsoft® DOS (MS-DOSR) operating
system. DOS Shell lets you take advantage of the power of MS-DOS with a few
keystrokes, or a click of a mouse. DOS Shell lets you perform many tasks—the
most fundamental being the ability to start and organize your programs, and
work with your files.

Using DOS Shell, you will make selections on screens and choose commands
from menus using either the keyboard or a mouse. A menu is a list of actions
organized on your screen that you activate by pulling down the menu and
choosing the appropriate command.

In this chapter, you will learn to:

m Start and exit DOS Shell
s Identify what you see on a screen
m Use DOS Shell with a keyboard or a mouse

What You Need to Use DOS Shell
To use DOS Shell, you need the following:

m A personal computer with MS-DOS version 4.0 installed
m At least 256 kilobytes (KB) of memory (512 KB of memory is recommended)
m A monitor

There are some additional things that can make DOS Shell even more useful.

m A graphics adapter card. DOS Shell supports many different graphics
adapter cards.
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m A serial or bus mouse
s A printer connected to your computer

If you do not have a graphics adapter installed in your system, your screens
will look somewhat different than the ones in this guide. In particular, you will
not see any graphic icons or other special effects.

Note This guide assumes you have installed DOS Shell on a fixed
i disk or on 720 KB flexible disks. If you have installed DOS
t Shell on 360 KB flexible disks, you will need to swap disks

in order to use the Format, Disk Copy, Disk Compare, and
Chkdsk commands. Before choosing the Format or Disk Copy
commands, insert the disk “Workingl.” Before choosing

the Disk Compare or Chkdsk commands, insert the disk
“Working2.” After completing these commands, insert the disk
“Shell.” You’ll return to DOS Shell.

Can You Harm a Computer?

Most beginning computer users are a bit cautious when they start using their
computers. It’s natural to wonder what will happen if you push the wrong
button.

You can’t harm your computer just by using it, even if you do something
wrong. However, the programs in DOS Shell let you delete files and directories
from your computer, so you should double-check your selections when you
perform these tasks.

Stopping a Process

If you choose a command from a menu and then decide that you want to quit
and return to your previous screen, press (Esc). In most cases, this action takes
you back to your active screen—the screen you were last working with. For
example, if you begin to delete a file and then realize you don’t want to, just

press (Esc).
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Looking at DOS Shell

DOS Shell lets you run programs—a set of instructions to the computer—to
perform specific tasks. Using the selection cursor, you select programs from the
title list of a DOS Shell screen. Each screen is designed to make working with
your programs easy.

Title list
Menu bar Title bar

Start Programs

Program Group Exit

Main Group
Yo select an item, use the up and doun arrous,
To start a program or display a new group, press Enter.

Command Prompt

File System
Change Colors
DOS Utilities...

=Computer

Museum

FiB=Actions Shift +F9=Command Prompt

Selection cursor

These are the programs you can start from
the title list of the Start Programs screen.
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Running Programs Is Easy

Choose commands and programs using your keyboard, a mouse, or both
together.

The Program menu commands are in this drop-down menu.

i Start Programs

Program | Group Exit

Y Main Group
select an iten, use the up and doun arrous.

rt a program or display a new gronp, press Enter.

add. ..

FiB=Actions Shift+F9=Command Prompt

SINE :

Or, just point with the mouse and click.'
!

You can use the DIRECTION keys (UP, DOWN, RIGHT, and LEFT)
to move around the screen.
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How DOS Shell Will Help You

The Start Programs and File System screens are the fundamental screens of
DOS Shell. Start Programs lets you start and organize your programs, while
File System lets you work with your computer directories and files. Here are
the kinds of things you can do with MS-DOS Shell:

m The Start Programs screen is the first screen you see when you start DOS
Shell. The Start Programs screen also contains the Main Group of programs
of DOS Shell. You can start programs from this screen, add or delete
programs, and change the order in which you list the programs.

m The File System screen shows you a list of all the files in the current
directory. You can look at the contents of your files and print them from the
File System screen. You can also move files from one directory to another,
rename them, and delete them.

m The Change Colors screen lets you view up to four different color schemes
and then select the one you want to work with during your working session.

m The DOS Utilities screen shows a group of frequently used MS-DOS
commands. You can change the date and time on your computer, format
disks, and back up and restore your disk files using the commands from this
screen.

m You can perform any MS-DOS command not accessible from DOS Shell from
the MS-DOS prompt and then return to DOS Shell as you like.

Starting DOS Shell

When you install MS-DOS on your computer, you have the option to have
DOS Shell start automatically. If you’ve set up MS-DOS to have DOS Shell
start automatically, all you need to do is turn on your computer and you’ll see
the Start Programs screen.

You can also start DOS Shell from the MS-DOS prompt. To start the program
type DOSSHELL at the MS-DOS prompt and press (Enter).

The Start Programs screen appears.
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Menu bar
Title list Title bar

; Start Prograns
Program Group Exit Fi=Help
Main Group
To select an item, use the up and down arrous,
Tn start a program or display a new gronp, press Enter.

Command Prompt
F

ile Systen
Change Colors
DOS Utilities...

FlB=Actions Shif t+F9=Command Prompt

Selection cursor Key definition line

1-6 Getting Started



Elements of the Start Programs Screen

Here’s a listing of each screen element and what it does.

Screen Element

Menu bar

Key definition line

Selection cursor

Title bar

Title list

Definition

shows the titles of the available menus. You choose
commands from these menus to manage programs, and
groups, and to exit DOS Shell.

displays function key information for each screen. The
keys and key combinations serve as a reminder of which
function keys perform basic operations such a moving
to the menu bar, moving to another screen or returning
to the MS-DOS prompt.

shows where you are on the screen. If you have a mouse
installed, you will also see an arrow pointer.

displays the name of the screen—in this case, Start
Programs. The date and time are also displayed.

displays a list of programs and groups. The programs
listed on the Start Programs screen make up the Main
Group of programs. Group titles are easily recognized
because they are followed by three dots.

How to Exit DOS Shell

There are two ways to exit DOS Shell:
m Press until the MS-DOS prompt appears.

m Choose the Exit Shell command from the Exit menu on the Start Programs

screen.

You'll see a blank screen and the MS-DOS prompt or see the PAM Main menu.
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Some Things You Need to Know

On the next few pages, you’ll find some general information about using DOS
Shell. You’ll learn how your computer stores information and how to use the
keyboard and mouse.

Storing Information

Files and directories are the storage units MS-DOS uses to organize
information that is stored in the computer.

The basic unit for storing information is a file and files are stored in a
directory. You could think of a directory as a file drawer where you store your
file folders. To help understand the MS-DOS file system, you can picture the
information as being in the files, and the files as being in the directories.
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An MS-DOS directory is like a file drawer;
it contains files.

invest file folder Word file folder

An MS-DOS file is like a file folder;
it contains information.
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Because a computer can store many files and directories, you must have a
way to tell them apart. You give each file and directory a name. You tell the
computer these names when you want to locate your files. For example, files
and a directory might be named as follows:

Jan.inv Feb.inv

The top directory is C:\. You can create other directories, called
subdirectories, under this one. The File System screen shows your files and
directories in a tree structure. A directory tree looks like an organizational
chart, but it shows your directories and subdirectories as paths along the tree
structure.

Using the Keyboard

In this manual, anything you should type verbatim appears in COMPUTER FONT.
For example, if you’re asked to type a file called MYLIST.TXT, what you
actually type is shown like this: MYLIST.TXT.

To DOS Shell, there is a difference between the numeral zero (0) and the
capital letter O. DOS Shell also distinguishes between the numeral one (1) and
the small letter 1. These characters may look similar to you, but they mean
different things to the computer, so be sure you use the correct key. DOS Shell
can’t tell the difference between uppercase and lowercase letters, so you can
type commands or file names either way.
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The keys defined in the following list let you move around on the screen, select
menus, choose commands, and get help when you need it.

Key

WOO®

F1l

F2

-n
w

BE
-y

-
©

g

F1

Fl1

(Pg Up) and {Pg Dn)

Tab

Definition

move the selection cursor on your screen. These keys
are also called the direction keys.

completes a command. By pressing this key, you tell
the computer to perform a task.

lets you exit from a menu to your active screen. You
can also exit most of the screens and return to the
Start Programs screen using this key. To exit the File

System screen, press (F3).

shows help information for any topic you select.

lets you save the information typed into the text box of
a dialog box. You also use this key to copy a program
to another screen.

lets you quit from any screen and from DOS Shell.

creates a mark that separates the commands typed into
the text box of a dialog box.

displays the key assignments within a help information
box. It also switches you from ASCII to hexadecimal
format and back within the View command.

moves the selection cursor between the menu bar and
the selection area of your screen.

displays an index of help topics within a help
information box.

move you into new screens of text in a help information
box or through a file using the View command. For
more information about the View command, see
Chapter 2 “Learning About DOS Shell.”

lets you move around in the File System screen and
in a dialog box. For more information about dialog

Getting Started 1-11



Spacebar

@@

boxes, see Chapter 2 “Learning About DOS Shell.”
(Shift}+(Tab) moves the selection cursor backward.

selects one or more files in the File System screen.

increases the actions available from your standard
keyboard when used with other keys. For example,
Press (shift}+(Fe) means that you should press and
hold it down while you press and release (F9). Then
release (Shift).

displays an index of all of the help topics in the help
information box.

Along the bottom and in the upper right corner of each screen, you will find
an area which provides you with different avenues to work with or cancel
commands. For example, F1=HELP means to press to get help on any item
you have selected. If you are using a mouse, you simply click on this area of
your screen to see the help information for the item you’ve selected.

In dialog boxes, these key areas appear as buttons. Press the specified key or
click the button with the mouse to activate the function.

Key

(Esc)=Cancel

(F1)=Help

(F10)=Action

(shift}+(Fo)=Command
Prompt
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complete a command by pressing or
clicking the ENTER area with a mouse.

cancels the action you have selected. Click this
area with a mouse or press (Esc).

displays help information for the item you have
selected. Click this area with a mouse or press

(FL).

moves you to the menu bar to choose a
command. Click this area with a mouse or press
F10 ).

exits DOS Shell and return to the MS-DOS
prompt. Click this area with a mouse or press

G+



Using a Mouse

A mouse is a small, hand-held pointing device that you can use to move around
a screen, select items, and choose commands. Moving the mouse across your
desk moves a pointer on your screen. The pointer can be either an arrow or

a small rectangle. If you’re using a mouse with two or more buttons, always
press the left button when making selections.

If you run out of room on your desk while you’re moving the mouse, simply
pick it up, reposition it, put it back down, and continue with what you were
doing.

The following terms are used in this guide to describe actions with a mouse:

Term Definition

Click quickly press and release the mouse button.

Drag press the mouse button and hold it down while moving the
mouse.

Double-click click the mouse button twice very quickly. If nothing

happens when you double-click the mouse on something,
try double-clicking again. Vary the time between clicks
until you find the right speed for your mouse.

Point move the mouse on your desk until the tip of the arrow
rests against the item being described.
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Learning About DOS Shell

In this chapter, you will learn to:
m Start programs
m Get help

m Select a menu and choose a command

m View, copy, and delete your files
m Reorder your files

m Use DOS Utilities

m Move to the MS-DOS prompt

m Change the colors on your screen

Now that you’re familiar with the basic principles of DOS Shell, you’re ready
for some hands-on experience. The following exercises will help you work with
application programs, disks, and files. Each exercise is presented with keyboard
instructions first and mouse instructions second.

If you’re a new user, you’ll find this section especially helpful. The step-by-step
instructions will tell you exactly what to do and what the results will be.
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Exercise 1: Starting a Program

Let’s begin by looking at the Start Programs screen. Each program on the
title list performs a different task. In this exercise, you’ll start the File System
program, which displays a new screen, where you’ll work with files.

Starting DOS Shell
If DOS Shell isn’t already started on your computer, do the following:

m If DOS Shell starts automatically, simply turn on your computer and begin
working.

m If DOS Shell doesn’t start automatically, type DOSSHELL at the MS-DOS
prompt and press (Enter).

Starting the File System Program
Using the keyboard:

1. Press () or (¥) until the selection cursor rests on the File System program
name.

2. Press (Enter). The File System screen appears.
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Using the mouse, double-click the File System program name. The File System
sCreen appears ON your screen.

Directory identifier

Drive identifier Menu bar Title bar File list
File Options Arrange Exit Fi=Help
Ctrl+letter selects a drive.

= =B
C:\DOS
Directory Tree I x %
: 4+
C:N E IAPPEND  ,EXE 11,113 85-14-88) &
INDOWS ASSIGN .COM 5,808 #5-14-88
EXCEL ATTRIB  .EXE 18,238 65-14-88
J < D08 AUTOEXEC .BAT 92 66-16-88
ORD BACKUP .COM 33,759 05-14-88
ORKS BASIC  .COM 1,088 #5-14-88
BASICA .COM 36,285 65-14-88
CHKDSK  .COM 17,618 #5-14-88
ICOMMAND .COM 37,539 66-89-88
=ICOMP .COM 9,498 65-14-88
EE4CONFIG  .SYS 149 66-69-88
FHCOUNTRY .SYS 12,861 05-14-88
=DEBUG  .COM 21,613 85-14-88
=DISKCOMP .COM 9,912 65-14-88
p =)DISKCOPY.COM 10,451 05-14-88 | [¥
EE4DISPLAY .SYS 15,756 05-14-88) |+
FiB=Actions Shift+F9=Command Prompt
Directory tree Scroll bars

Getting Help

You can get help information about any menu, option, and command.

Using the keyboard:

1. Press to move to the menu bar. You have selected the first menu, File.

2. Press (F1). You’ll see a help dialog box that contains information about the
File menu.

3. Press (4) or (¥) to move through the help dialog box. Or, you can use
(Pg up) or (Pg Dn). This action is called scrolling.
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4, You can get an index of all the topics in your help box by pressing or
(ALT)+(F1). You can choose any topic from this index.

5. Press two times when you finish looking at the help information.
Using the mouse:
1. Click the File menu.

2. Click the FI=HELP area at the top of the screen. You’ll see a help dialog
box that contains information about the Open command.

3. Click the scroll bar to move through the information box. This is called
scrolling.

4. Click the ESC=CANCEL area located at the bottom of the dialog box when
you’ve finished reading the help information and want to return to your
active screen.

Changing the Directory

You can view different file lists by simply changing the current directory to
another directory or drive. For example, you can examine the files in the root
directory (C:\ for a hard disk or A:\ for a flexible disk), and then change
directories to look at the contents of the DOS directory.

Using the keyboard:
1. Press two times to move to the directory tree.
2. Press the direction keys to select the root directory.

3. Press (Enter). A mark appears to the left of the name of the root directory.
The name of the directory appears in the directory identifier.

To move to a different disk drive on the File System screen, follow these steps:
1. Press to move to the drive identifiers.

2. Press the direction keys to move to drive B:.

3. Press (Enter).

Your file list changes as you select different directories.
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Using the mouse:

Click the root directory. A mark appears to the left of the name of the root
directory. The name of the directory appears in the directory identifier.

To change drives, click drive B:. Your file list changes as you select different
directories.

Returning to Your Original Drive
Using the keyboard:

1. Press the direction keys to select drive A: (flexible disk) or drive C: (hard
disk).

2. Press (Enter).

Using the mouse, click the A: drive identifier (flexible disk) or C: drive
identifier (hard disk).

Exercise 2: Working With Files

In this exercise, you’ll have a chance to scroll through a file list and view the
contents of a file.

There are more file names in the DOS directory than can fit in the file list.
You can easily move through the list to see all of the names.

Scrolling Through the File List
Using the keyboard:

Scroll through the file names on the File System screen by following these
steps:

1. Press to move to the file list.

2. Press (4) and () to move up and down the list. You can also press the
and keys to move quickly through large lists.
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Using the mouse:
1. Move the pointer to the Up or Down arrows on the scroll bar.

2. Click the mouse. There are several techniques you can use to scroll with the
mouse:

m Click the single arrow in the scroll bar to move one file name at a time.
m Click the double arrows in the scroll bar to move one screenful at a time.

s Drag the scroll bar to scroll through the file list in increments of your
choice.

Viewing the Contents of a File

You use the View command to see the contents of a file. Not all of the files
listed in the file list should be viewed however. So, when you select files to
view, make sure they are either a batch file (a file ending with the .BAT file
name extension) or files that you know contain text. For example, try viewing
a file you have created with a word processing application. Text files often have
.DOC or .TXT extensions. You shouldn’t try to view program and command
files that have .EXE or .COM extensions. If you do accidentally select one of
these files for viewing, you will see garbled text.

Now let’s view the DOSSHELL.BAT file in the DOS directory. Before you can
view a file, you must select it. Here’s how to select the DOSSHELL.BAT file
for viewing.

Using the keyboard:

1. Press to move to the file list.

2. Press (&) or (v) to move to the DOSSHELL.BAT file.

3. Press the Spacebar. You have selected the DOSSHELL.BAT file.

Note Selecting a file is a two-step process when you’re using the
i keyboard. First you move to the file name, and then you
ﬁ press the Spacebar to make the selection. You know the file is

selected when the greater-than sign (>) appears beside the file
name or when the file icon darkens. If you press the Spacebar
again, the selection is canceled.
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Using the mouse:

1. Move the mouse pointer to the file named DOSSHELL.BAT.

2. Click the mouse. You have selected the DOSSHELL.BAT file. If you click

the mouse again, the selection is canceled.

With the DOSSHELL.BAT file selected, you are ready to use the View

command on the File System screen.

Choosing the View Command
Using the keyboard:
1. Press to move to the File menu.

2. Press the underlined letter, F, to open the File menu.

3. Press the underlined letter, V, to choose the View command. You can also
press (¥) to move to the View command and then press (Enter). The contents

of the DOSSHELL.BAT file appears on your screen.

Fi-Help

File View
To view a file’s content press or (@D,

Uiewing file: C:N\DOS\DOSSHELL.BAT

SHELLB DOSSHELL

IF ERRORLEVEL 255 GOTO END

:COMMON

SHELLC /TRAN/COLOR/DOS/MENU/MUL/SND/MEU : SHELL . MEU/CLR : SHELL . CLRZPROMPT/MAINT/EX
IT/SWAP/DATE

:END

FBRERKZON

{=Enter Esc=Cancel F9-Hex/ASCII

Learning About DOS Shell

2-7



Using the mouse:
1. Click File on the menu bar.
2. Click View. The DOSSHELL.BAT file appears on your screen.

Returning to the File System Screen

Using the keyboard, press the key. Notice that the DOSSHELL.BAT
file is no longer selected. Most selections are canceled after you complete a
command.

Using the mouse, click the ESC=CANCEL area located at the bottom of the
screen. The DOSSHELL.BAT file is no longer selected and the File System
screen appears.

Exercise 3: Using the Copy and Delete Commands With
Files

You can use DOS Shell to copy files from one directory to another. If the
destination directory doesn’t exist, you must create it before you can copy any
files into it.

In this exercise, you’ll learn how to create a new directory, copy a file from one
directory to another, and delete a file.

Let’s create a new directory named TEST to use in this exercise. Move to the
File System screen and create the TEST directory.

Creating a New Directory

Using the keyboard:

1. Press two times to move to the directory tree.
2. Press to select the C:\ directory.

3. Press to move to the File menu.

4. Press the underlined letter, F, to open the File menu.
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5. Press the underlined letter, E, to choose the Create directory command.
The Create Directory dialog box appears:

Create Directory
Neuw directory name. . :]

( (T=Enter ) { Esc=Cancel ) (Fi=Help

6. Type TEST in the New directory name text box.

7. Press (Enter). Your new directory—TEST—is created.
Using the mouse:

1. Click the root directory (C:\) in the directory tree.
2. Click the File menu.

3. Click the Create directory command. A dialog box appears.

Create Directory

New directory name. . :

{(J=Enter ) (Esc=Cancel ) (FizHelp )

4. Type TEST in the New directory name text box.
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5. Click the ENTER area at the bottom of the dialog box.

Copying a File

At times, you may want to make changes to a file but keep the original file as it
is. The Copy command makes a copy of the file while leaving the original file
unchanged.

In this part of the exercise, you’ll copy the file named AUTOEXEC.BAT in the
DOS directory to the TEST directory you’ve created.

Using the keyboard:

1.
2.

® N> oo s w

Press to move to the directory tree.

Press to select the root directory. You will be at the root of the
directory tree (C:\ for a hard disk, A:\ for a flexible disk). The root
directory now becomes the source directory.

Press to move to the file list.

Press the direction keys to move to the AUTOEXEC.BAT file.
Press the Spacebar to select the AUTOEXEC.BAT file.

Press to move to the File menu.

Press the underlined letter, F, to open the File menu.

Press (¥) to choose the Copy command, or you can simply type the
underlined letter, C, to choose the Copy command.
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9. Press (Enter). A dialog box appears.

The file you selected appears
in the From: text box.

| Copy File NN
From: | 'AUTOEXEC.BAT ]
To: [N [»]

{ (I =Enter )| Esc=Cancel | { Fi=Help |

Type the directory name
in the To: text box.

10. Press @ to move in the text box.

11. Type TEST in the To: text box after the C:\. The text C:\TEST in the
text box tells DOS Shell to copy the AUTOEXEC.BAT file to the TEST
directory on the C:\ drive.

12. Press (Enter). You'll see a message that indicates your file is being copied.
Using the mouse:

1. Click the directory tree.

2. Click the AUTOEXEC.BAT file in the file list.

3. Click the File menu.
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4. Click the Copy command. A dialog box appears.

The file you selected appears
in the From: text box.

I Coyy Filc NN
From: [TRUTOEXEC.BAT [+
o [EN o

{ <I=Enter j| Esc=Cancel || Fi=Help |

Type the directory name
in the To: text box.

5. Press (») to move in the text box after the C:\.

6. Type TEST in the To: text box after the C:\. The text C:\TEST in the
text box tells DOS Shell to copy the AUTOEXEC.BAT file to the TEST
directory on the C:\ drive.

7. Click the ENTER area. You'll see a message that indicates your file is being
copied.

Deleting a File

The Delete command is a powerful command. You use the Delete command to
remove a file from your computer. For example, you might want to delete a file
because the information in it is outdated. Before using this command, be sure

there is nothing in the file you want to keep: once you delete a file, you cannot
get it back.

Here’s how to delete the duplicate copy of your AUTOEXEC.BAT file that you
just copied to the TEST directory.
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Using the keyboard:

1.
2.
3.

10.

Press to move to the directory tree.
Press (v) to move to the TEST directory.

Press to select the TEST directory. Notice that the
AUTOEXEC.BAT file is in the file list to the right of the directory tree.

. Press to move to the file list.
. Press the Spacebar to select the AUTOEXEC.BAT file. It is the only file

in your TEST directory.

. Press to move to the File menu.
. Press the underlined letter, F, to open the File menu.

. Press the underlined letter, D, to choose the Delete command. A dialog

box appears on the screen.

Delete File

Delete . . [ |AUTOEXEC.BAT =]

( (J=Enter ) (Esc=Cancel } {FisHelp

“AUTOEXEC.BAT” appears in the text box, so you can confirm what you
are about to delete.

. Press to delete the file. Another dialog box appears so you can

confirm the Delete command.

Type 2. Notice that your directory tree looks just as it did before you
deleted the file. But the file list has changed. AUTOEXEC.BAT is not
in the file list, and a message indicates that no files exist in the TEST
directory.

Using the mouse:
1. Click the TEST directory in the directory tree.
2. Click the AUTOEXEC.BAT file in the file list.
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3. Click the File menu in the menu bar.

4. Click the Delete command. A dialog box appears, allowing you to confirm
the file you are about to delete.

5. Click the ENTER area at the bottom of the dialog box. Another dialog box
appears, giving you another chance to confirm your choice.

6. Click option 2.

7. Your directory tree looks just as it did before you deleted your file. But the
file list has changed. AUTOEXEC.BAT is not in the file list, and a message
indicates that no files exist in the TEST directory.

Canceling a Selection

If you choose a command or select an option by mistake, you can always cancel
the selection. Canceling a selection returns you to the state you were in prior
to choosing or selecting.

You can cancel a command or selection at any time. Press or click the
ESC=CANCEL area.

Exercise 4: Organizing Files

You’ve been working with the directory tree and file list in the last few

exercises. In this exercise, you’ll change the way your files are organized in the
file list.

The file list you see when you move to the File System screen contains all of
the files in the current directory listed in alphabetical order. With the Display
options command, you can display a subset of the files listed in the directory
and sort them by file name, file name extension, creation date, file size, and the
disk order the files physically occupy on the disk.
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Reordering Files

Follow these steps to change the order of your DOS directory file list on the
File System screen.

Using the keyboard:

1. On the File System screen, press to move to the directory tree.
2. Press the direction keys to move to the DOS directory.

3. Press (Enter).

4. Press to select the menu bar.

5. Press the underlined letter, O, to open the Options menu.

6

. Press to choose the Display options command. The Display Options
dialog box appears.

These are wildcards.

Display Options W
Name ! E.*

Sort by:

3 Name
)l Extension |
i+ Date
1 Size
"+ Disk order

[ (-T=Enter | [ Esc=Cancel j| Fi=Help |

Select the Extension sort order.

The sorting options provide different ways for your files to be sorted.
1. Press to move to the first sorting option.
2. Press (¥) to select the Extension option.

3. Press (Enter).
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Using the mouse:
1. On the File System screen, click the DOS directory on the directory tree.
2. Click the Options menu.

3. Click the Display options command. The Display Options dialog box
appears.

4. Click the Extension option.

5. Click the ENTER area at the bottom of the dialog box. Your files are now
ordered alphabetically by file name extension.

Wildcards (*.*) indicate all files should be listed. You can use other wildcards
and file names (or file name extensions) to select a specific set of files. For
example, if you wanted to only list your word processing files (files with a
.DOC extension), you would type *.DOC in the Name text box. You can type
your own file names or use wildcards to modify the files that appear in your
lists. For more information about wildcards and file names see your MS-DOS
User’s Reference manual.

There are many more File System functions available than are discussed in this
exercise. Chapter 3 “Using DOS Shell” explains all of the options in detail.

Leaving the File System Screen

Using the keyboard, press (f3). The Start Programs screen appears.

Using the mouse:

1. Click the Exit menu.

2. Click the Exit File System command. The Start Programs screen appears.

You can select other programs from the title list. You can also add new
programs to the Start Programs screen. You can learn about adding programs

to the Start Programs screen by reading the appropriate section in Chapter 3
“Using DOS Shell.”
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Exercise 5: Working With DOS Utilities

The Start Programs screen contains the Main Group of programs in DOS Shell.
DOS Utilities is one of the members of this Main Group. When you select DOS
Utilities, a new screen appears showing you another list of programs.

To begin this exercise, move to the DOS Utilities screen.

Moving to the DOS Utilities Screen

Using the keyboard:

1. Press (4] or (¥] to select the DOS Utilities screen.
2. Press (Enter). The DOS Utilities screen appears.

Using the mouse, double-click the DOS Utilities title on the Start Programs
screen.

-Computer

%Mu seum

Menu bar
Title bar

. Start Programs
Program Group Exit Fi-=Help
DOS Utilities...
To select an item, use the up and down arrvous.
Tno start a program or display a new gronp, press Enter.

Set Date and Time

Disk Copy

Disk Compare
Backup Fixed Disk
Restore Fixed Disk
Format

FiB=Actions Esc=Cancel | Shift+F9=Command Prompt

Title list Selection cursor
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Formatting a Disk

You use the Format command to prepare a disk (hard or flexible) to hold files
and directories. To perform this exercise, you’ll need a flexible disk that is
compatible with your disk drive.

The Format command erases all information previously stored on the flexible
disk so be sure the disk doesn’t contain any important information. For more
information about formatting a disk, see your MS-DOS User’s Reference
manual.

Here’s how to format a flexible disk on the DOS Utilities screen.
Using the keyboard:

1. Press (&) or (¥) keys to choose the Format command from the DOS Utilities
title list.

2. Press (Enter). The Format Utility dialog box appears.

—_—

Enter drive to Format.

Parameters . . [ R: [+

{ (T=Enter | [ Esc=Cancel | [ Fi=Help |

3. Press to format your disk in drive A:. The DOS Utilities screen
disappears and the following message appears:

Insert new diskette for drive A:
and press ENTER when ready ...

4. Insert the disk in drive A: and close the door.

5. Press (Enter). The formatting process begins. After the formatting is
complete, a message appears:

Volume label (11 characters, ENTER for none)?
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MS-DOS is prompting you to give the disk a name, or label. This is an
optional step.

6. Type MYDISK at the prompt.

7. Press (Enter). A message appears on the screen providing information about
the disk, followed by:

Format another (Y/N)?

8. Type N and press (Enter).

9. Press any key on the keyboard to return to the DOS Utilities screen. Your
disk is now ready to store files and directories.

Using the mouse:

1. Double-click the Format command on the DOS Utilities title list. The
Format Utility dialog box appears.

IR Fornat Utility I
Enter drive to Format.

Parameters . . [ h: [+

[ <(J=Enter | [ Esc=Cancel | | F1=Help |

2. Click the ENTER area at the bottom of the dialog box to format the disk
in drive A:. The DOS Utilities screen disappears and the following message
appears:

Insert new diskette for drive A:
and press ENTER when ready ...

3. Insert the disk in drive A: and close the door.

4. Press (Enter). The formatting process begins. After the formatting is
complete, a message appears:

Volume label (11 characters, ENTER for none)?
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MS-DOS is prompting you to give the disk a name, or label. This is an
optional step.

5. Type MYDISK at the prompt.

6. Press (Enter). A message appears on the screen providing information about
the disk, followed by:

Format another (Y/N)?

7. Type N and press (Enter).

8. Press any key on the keyboard to return to the DOS Utilities screen. Your
disk is now ready to store files and directories.

Setting the Date and Time

The date and time appear on the title bar of the Start Programs and File
System screens. You can change them easily using the Set Date and Time
command on the DOS Utilities screen.

Unless you have a clock in your system, you will want to set the date and time
each time you start your computer.

Follow these steps to reset the date and time.

Using the keyboard:

1. Press (&) or (¥) to select the Set Date and Time command.
2. Press (Enter). A dialog box appears.

Type the new date in the text box.

Date d

Enter new date ?7-77-77

Parameters . I:/

{ (J=Enter | [ Esc=Cancel | [ Fi=Help ]
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3. Type 06-07-89 in the text box to set the date to June 7, 1989. Use the
numbers 01 to 12 to represent the month, 01 to 31 the day, and 80 to 99 the
year. Separate the numbers with a hyphen.

4. Press (Enter). Another dialog box appears.

Type the new time in the text box.

Set Date and Time Utility

Enter neu time hhimm

Parameters . .

{ <T=Enter | { Esc=Cancel | [ F1=Help |

5. Type 13:15 to set the time to 1:15 p.m. Use the numbers 00 to 23 to

represent the hour and 00 to 59 to represent the minute. Separate the
numbers with a colon.

6. Press (Enter). The DOS Utilities screen disappears and you’ll see the
following message on your screen:

Press any key to continue ...

7. Press any key on the keyboard to return to the DOS Utilities screen.

Using the mouse:

1. Double-click the Set Date and Time command. A dialog box appears.

Type the new date in the text box.

Enter new date 77-77-77

Parameters . . ‘:j/

{ (J=Enter } [ Esc=Cancel || FizHelp |
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2. Type 06-07-89 to set the date to June 7, 1989. Use the numbers 01 to 12
to represent the month, 01 to 31 the day, and 80 to 99 the year. Separate
the numbers with a hyphen.

3. Click the ENTER area at the bottom of the dialog box. A dialog box
appears.

Type the new time in the text box.

Date

Enter new time hhimm

Parameters . .

[ (J=Enter || Esc=Cancel | [ Fi=Help |

4. Type 13:15 to set the time to 1:15 p.in. The numbers 00 to 23 represent the
hour and 00 to 59 represent the minute. Separate the numbers with a colon.

5. Click the ENTER area at the bottom of the dialog box. The DOS Utilities
screen disappears and you'll see the following message on your screen:

Press any key to continue ...

6. Press any key on the keyboard to return to the DQOS Utilities screen.

Returning to the Start Programs Screen

You always return to the Start Programs screen before you can leave DOS
Shell. You can return to the Start Programs screen from any other screen.

Using the keyboard, press (Esc). (To return to the Start Programs screen from
the File System screen, press (F3).)

Using the mouse, click the ESC=CANCEL area at the bottom of the screen.
(To return to the Start Programs screen from the File Systems screen, choose
the Exit File System command from the Exit menu.)
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Exercise 6: Working at the MS-DOS Prompt

DOS Shell contains many MS-DOS commands. However, it does not contain
all MS-DOS commands. You might find it necessary, from time to time, to exit
DOS Shell and perform your work at the MS-DOS prompt. You can return to
DOS Shell without disturbing any of your tasks.

Checking Your Disks

You might wish to scan a flexible disk to check it for errors using the Chkdsk
command. Here’s how you can check your disk.

Using the keyboard:

L. Press the (shift}+(F9) keys. This action is the same as choosing the
Command Prompt program from the Start Programs title list. You can exit
DOS Shell from all screens except the Change Colors screen. You'll see a
message at the top of your screen:

When ready to return to the DOS Shell,
type EXIT then press enter.

2. Type CHKDSK at the MS-DOS prompt.

3. Press (Eater). MS-DOS gives you information about your total disk space,
directories, files, and available space on your disk.

To return to the screen you were working with before temporarily leaving DOS
Shell, follow these steps:

1. Type EXIT at the DOS prompt.
2. Press (Enter). You return to DOS Shell.

Using the mouse:

1. Click the SHIFT+F9=COMMAND PROMPT area at the bottom of the
screen. This action is the same as choosing the Command Prompt program
from the Start Programs title list. You can exit DOS Shell from all screens
except the Change Colors screen. You’ll see a message at the top of your
screen:

When ready to return to the DOS Shell,
type EXIT then press enter.
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2. Type CHKDSK at the MS-DOS prompt.
3. Press (Enter).

MS-DOS gives you information about your total disk space, directories, files,
and available space on your disk.

To return to the screen you were working with before temporarily leaving DOS
Shell, follow these steps:

1. Type EXIT at the MS-DOS prompt.
2. Press (Enter). You return to DOS Shell.

Exercise 7: Setting Your Screen Color

You’ve completed this tour of DOS Shell. There are many features that weren’t
covered in this chapter that you will want to explore. But with what you’ve
learned, you’re ready to use DOS Shell to organize your own programs and

files.

Before you move on, however, take the time to investigate one more feature:
the Change Color command. With this command, you can adjust the colors on
your computer screen.

DOS Shell has four different color schemes to choose from. If you don’t have a
graphics adapter, go on to Exercise 8.

Follow these steps to select new colors
Using the keyboard:

1. Press (&) or (v] to select the Change Colors program from the Start
Programs title list.
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2. Press (Enter). A new screen appears with a display of the colors you are
currently using.

#7-18-88 Start Progranms 9:32 an
Fi=Help

Change Colors 1

To change colors use (#3 and (#}. Press Enter to
save current color selections or Esc to Cancel.

Sample color panels

(< =Enter ) ( Esc=Cancel ) [ Fi=Help )

{J=Enter Esc=Cancel

3. Press (4) and (») to view the different color choices.
4. Press to choose the color combination you like.

Using the mouse:

1. Double-click the Change Colors command. Sample color panels appear on
the screen.

2. Click the Left and Right keys shown on the screen to view the different color
choices.

3. Click the ENTER area at the bottom of the screen to choose the color

combination you like. You’ll see the Start Programs screen with the color
scheme you selected.
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Exercise 8: Exiting DOS Shell

You can leave DOS Shell any time you want. You’ve already learned how to
temporarily leave DOS Shell and return to the same screen you left. In this
brief exercise, you’ll learn how to leave the system permanently.

If you are at the File System screen, you must return to the Start Programs
screen to leave the system. From the Start Programs screen, you can leave

DOS Shell.

Using the keyboard, press (F3).
Using the mouse:

1. Click the Exit menu.

2. Click the Exit Shell command.

After you leave the DOS Shell, the screen is blank except for the MS-DOS
prompt. From this prompt, you can carry out any MS-DOS command or
re-enter DOS Shell.
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Using DOS Shell

In this chapter, you will learn how to:

m Manage your disks

m Work with your directories, files, and application programs.
m Create and change groups of programs

In the previous chapter, you learned some basic techniques for working with
DOS Shell. This chapter gives you instructions for performing all the functions
DOS Shell provides. You’ll see instructions and examples for each task you
may want to perform to help you get the most out of DOS Shell.

The first section explains how to change the colors on your screen. Subsequent
sections explain how to work with disks, directories, files, and application
programs.

You may want to browse through this chapter first to see the range of functions
available. If you are using the programs for the first time, you’ll want to learn
such tasks as adding groups and programs, creating directories, and opening—
or starting—a command file. Once you are comfortable using DOS Shell, this
chapter will be a valuable reference tool.

You should already know how to move through the screens and make selections
within them, before you read this chapter. If you aren’t familiar with these
basic tasks, please review Chapter 2 “Learning About DOS Shell” before
continuing.

This chapter shows each task in as general a fashion as possible so that

keyboard and mouse users can follow the same instructions. For example, if
you're instructed to select the Program menu on the Start Programs screen,
you can either press or click the Program menu with a mouse. You will

see instructions for using the mouse only when they are different from keyboard
instructions.
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Note To choose an area means to either press the corresponding key
on the keyboard, or click the area (or button) with a mouse to
6 complete the command.

If you need more information about the specific tasks involved in any
procedure, see the corresponding exercise in Chapter 2. You can always press
to get help while you’re working.

Refer to the MS-DOS User’s Reference for comprehensive descriptions of all
MS-DOS commands.

Overview of DOS Shell

Microsoft DOS Shell is a graphic extension of the MS-DOS operating system.
DOS Shell lets you perform many tasks: the most fundamental being starting
and organizing programs, and working with files and directories.

The two primary screens of DOS Shell are Start Programs and File System.
You use Start Programs to start programs, organize your programs into logical
groups, and perform other tasks such as changing the color of your screen
(Change Colors program) and returning to the MS-DOS prompt. You use the
File System screen to work with your files and directories and perform tasks

such as listing your files, viewing the contents of a file, and copying or deleting
a file.
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When you start DOS Shell, the Start Programs screen appears. (The Start
Programs screen contains the Main Group of programs that make up DOS
Shell.)

Work with your files and directories

by choosing this title.

Exit MS-DOS Shell and return to the MS-DOS
command prompt by choosing this title.

A7-18-88
Program Group Exit

Start Programs

Main Group
To complete the reorder, highlight the neu
position, then press Enter. Press Esc to cancel.

Command Prompt

Change Colors
//EDOS Utilities...

F1B=Actions Shift+F9=Command Prompt

Work with a group of MS-DOS commands
by choosing this title.

Change the color of your screen by choosing
this title.

The names on the title list show you the names of other programs or
applications—ones that are part of DOS Shell and ones you add later. A group
is a collection of related programs. Notice the DOS Utilities title. This isn’t
the name of a single program or application. It’s the name of a group—a new
screen that contains programs. You can tell it’s a group because it has three
dots after its name.
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You’ll probably want to organize your programs into groups. If you put all of
your programs on the Start Programs screen, it would be difficult to find them

easily. Adding groups to DOS Shell gives you a way to organize your program
files.

You’ll learn more about groups in this chapter.

Right now, let’s look at the Change Colors command and work with the color
schemes this screen provides.

Working With Your Computer Screen
Computer screens come in a variety of sizes, shapes, and colors.

Your screen displays information in either color or monochrome. A
monochrome screen shows only one color but color screens give you a spectrum
of color options to choose from.

Changing Colors on the Screen

The Start Programs screen contains the Change Colors commandwhich lets you
adjust the colors of your monitor.

Using the Change Colors command, you choose from four preset screen color
sets and, regardless of whether you are using a color or monochrome monitor,
your screen’s appearance will change. If you do not have a graphics adapter
installed, this function is not available.

Follow these steps to select a new color scheme:
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1. Choose the Change Colors command from the Start Programs screen. The
color scheme you are currently using appears in the screen.

Fi=Help

Change Colors 1

To change colors use [#) and ). Press Enter to
save current color selections or Esc to Cancel.

Sample color panels

{J=Enter ) (Esc=Cancel ) (F1=Help

(=Enter Esc=Cancel

2. Scroll through the screens to view your choices using the direction keys.

3. Choose the ENTER area to select the color scheme you want. You’ll return
to the Start Programs screen and the colors you have selected now appear
On your screen.

There are other things you can change about your computer to assist you in
your work. For example, you can change the date and time which appear in
the title bar. The following section shows you how to change the date and time
and work with your hard and flexible disks.
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Working With Your Disks

The DOS Utilities group on the Start Programs screen contains all of the
commands that let you effectively manage your hard and flexible disks.

Moving to the DOS Utilities Screen

To move to the DOS Utilities screen and use the commands that let you work
with disks, choose the DOS Utilities command. The DOS Utilities screen
appears.

DOS Utilities is a group...

#7-18-88
Program Group Exit

Start Prograns

Fi=Help

DOS Utilities...
To select an item, use the up and doun arrous.
Tn start a program or display a new group, press Enter.

Set Date and Tinme
b

isk Copy
Disk Compare
Backup Fixed Disk
Restore Fixed Disk
Format

FiB=Actions Esc=Cancel Shift+F9=Command Prompt

...it contains a subset of MS-DOS utility
programs that let you work with your disks.

From the DOS Utilities screen, you can prepare flexible disks to receive
information and you can copy the information from one flexible disk to
another. You can also compare the contents of two flexible disks. DOS Utilities
lets you back up your files onto flexible disks so that you’ll have an extra copy
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in case your files are erased or otherwise destroyed. The backing up process
copies files from a hard disk onto flexible disks for safekeeping. DOS Utilities
lets you restore the contents of your flexible disk backup to the hard disk.

You can also set the date and time from the DOS Utilities screen.

Setting the Date and Time

The date and time always appear in the title bar at the top of the screen. You
can easily reset them if they are incorrect, or if your computer does not have a
built-in clock.

You change the date and time from the DOS Utilities screen. Here’s how to
reset the date and time:

1. Choose the Set Date and Time command. You’ll see a dialog box with
prompts for the new date.

Type the new date in the text box.

Set Date and Time Utility

Enter new date 77-77-77

Parameters . . [::::::Er//

{ (J=Enter | [ Esc=Cancel | {F1=Help |

2. Type in the date using the numbers 01 to 12 to represent the month, 01 to
31 the day, and 80 to 99 the year. Separate the numbers with a hyphen. For
example, May 1, 1989, would be typed as 05-01-89.
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3. Choose the ENTER area. You'll see a second dialog box, asking you for the
new time.

Type the new time in the text box.

Set Date and Time Utility

Enter new time hhimm

Parameters . .

[:(—J:Enter_][Esc:Cancel:H:Fl:Help:

4. Type in the time using the numbers 00 to 23 to represent the hour, and 00
to 59 the minutes. Separate the numbers with a colon. For example, 2:30
p-m. is typed as 14:30.

5. Choose the ENTER area. The DOS Utilities screen retreats and you'll see
the following message:

Press any key to continue ...

6. Press any key to return to the DOS Utilities screen. The date and time are
updated on the title bar.

Formatting Flexible Disks

Use the Format command from the DOS Utilities screen and follow these steps
to format a flexible disk:

1. Choose the Format command. A dialog box appears.

I ©ocrat Utility I

Enter drive to Format.

Parameters . . [ h: [»]

((—J:Enter 1 { Esc=Cancel ][Fl:Help]
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. Type the letter of the drive that contains the flexible disk to be formatted.
For example, drive A: appears by default in the Format Utility dialog box.

. Choose the ENTER area. The DOS Utilities screen retreats, and you'll see

this message:

Insert new diskette for drive A:
and press ENTER when ready.

4. Insert the disk in drive A: and close the door. The formatting process
begins. After the formatting is complete, a message appears:

Volume label (11 characters, ENTER for none)?
MS-DOS is prompting you to give the disk a name, or label.
5. Type a name at the prompt. This is an optional step.

6. Press (Enter). A message appears on the screen giving information about the

disk, followed by:

Format another (Y/N)?

7. Type Y if you want to continue the procedure. Type N if you wish to return

to DOS Shell.

8. Press (Enter).

9. Press any key to return to the DOS Utilities screen. The DOS Utilities
screen returns and your disk is now ready to store information.

There are many parameters available to you to make the Format command
more powerful. For example, you can use a parameter to format a flexible
disk and transfer system files onto it. This flexible disk is called a system or
bootable disk.

Refer to the MS-DOS User’s Reference for a list of the parameters to use with

the Format command.

Using DOS Shell
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Copying a Flexible Disk

You can use the Disk Copy command to duplicate the entire contents of
a flexible disk. To duplicate the contents of a hard disk, you must use the
Backup Fixed Disk command.

The disk to which you copy information is automatically formatted, and any
existing files are erased. If the disk has previously been used, check its contents
to ensure that you don’t destroy important files.

To copy a disk, do the following:

1. Choose the Disk Copy command from the DOS Utilities screen. A dialog
box appears.

Drive a is the source drive.

Enter sourice and destination drives.

SYRY =)

Drives . .

[ <J=Enter | [ Esc=Cancel ] [ Fi=Help )

Drive b is the destination drive.

The Disk Copy command copies the contents of the disk in the source drive
to the disk in the destination drive.

2. Type the letters of the source and destination drives. Be sure to include the
colon after each drive letter.

3. Choose the ENTER area. The DOS Utilities screen disappears and you’ll
see the following message:

Insert SOURCE diskette in drive A:

Press any key to continue ...

4. Press any key to continue the process. As MS-DOS copies the contents
of the source disk, it displays a message advising you of the status of the
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process. After the contents of the source disk are copied, you will see the
following message:

Insert TARGET disk in drive B:

Press any key to continue ...
5. Insert the disk to which you want to copy information.

6. Press any key to continue the process. When the copy process is complete,
you'll see this message:

Copy another diskette (Y/N)?

7. Type N if you don’t want to copy another disk or Y to copy more flexible
disks. If you choose to continue, DOS Shell asks you to insert your source
and target disks and performs the next copy on the drives that you
originally specified.

8. Press any key to return to the DOS Utilities screen. Your original disk has
been duplicated. After duplicating the contents of a disk, it is a good idea
to compare it with the original.

Comparing Two Disks

If you want to be sure two flexible disks contain identical information, the Disk
Compare command performs a comparison.

Disk Compare is useful if you have copied a flexible disk with the Disk Copy
command, and you want to ensure that the duplicate is an exact copy of the
original.

Here’s how to compare two disks:

Using DOS Shell 3-11



1. Choose the Disk Compare command from the DOS Utilities group. A dialog
box appears.

Type the drive letters in the text box.

I i skconp Utility |

Enter drive for comparisoi”

Parameters . . | h! b: [+]

{(J=Enter | [ Esc=Cancel | { F1=Help |

2. Choose the ENTER area. The DOS Utilities screen retreats while the
comparison is in progress.

You will see the following message:

Insert FIRST diskette in drive A:
Insert SECOND diskette in drive B:

Press any key to continue ...
3. Insert the disks you want to compare in drives A: and B:.

4. Press any key to continue the comparison. As MS-DOS reads the contents
of the disks, it displays a message advising you of the status of the process.
If the disks are the same, you will see the following message:

Compare 0K
When the comparison is completed, you’ll see this message:

Compare another diskette (Y/N)?

5. Type N if you don’t want to compare another disk or Y to continue
comparing flexible disks. You’ll see this message:

Press any key to continue ...
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6. Press any key to return to the DOS Utilities screen.

Backing Up Hard Disk Files to Flexible Disks

You can easily copy files from a hard disk to a flexible disk using the Backup
Fixed Disk command. Backing up is a more powerful process than copying.

It destroys any existing information on your flexible disks before the backup
information is copied onto them.

Back up your hard disk as often as you feel the need to protect the stored
information in your computer. Depending on the amount of information stored,
you may need multiple flexible disks.

Note You can only use the Backup Fixed Disk and Restore Fixed
i Disk commands if you have DOS Shell installed on a fixed disk.

There are a variety of parameters that let you back up only certain files, such
as those that have been changed since the last backup.

To copy files from a hard disk to a flexible disk, follow these steps:

1. Choose the Backup Fixed Disk command from the DOS Utilities screen. A
dialog box appears, giving you the option to back up all hard disk files to
the flexible disk in drive A:.

Destination drive
Source drive

Enter source and déstinatjon drives.

Parameters . . [ fi\..xa: /s [4]

([ (J=Enter ] { Esc=Cancel | [ Fi=Help |

These parameters back up all the files on
the fixed disk during the backup procedure.
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2. Type the drive letter and the path name of your source files and the
destination drive name. Include any parameters you want to use.

3. Choose the ENTER area. A warning message appears on the screen:
Insert backup diskette in drive A:
WARNING! Files in the target drive will be

erased.
Press any key to continue ...

4. Press any key to begin the process. The Backup Fixed Disk command
formats the flexible disk in drive A: before it transfers files to the disk. After
the formatting is complete:

Press any key to continue ...

5. Press any key to begin transferring the files. MS-DOS lists the files it is
backing up on the screen. After all the files are transferred to the flexible
disk, you will see this message:

Press any key to continue ...

6. Press any key to return to the DOS Utilities screen. Your hard disk files
are now on the flexible disk or disks. You may return them to a hard drive
using the Restore Fixed Disk command.

Restoring Hard Disk Files From Flexible Disks

After you back up files, you can easily return them to a hard disk with the
Restore Fixed Disk command.

You can only restore files that were saved to a flexible disk with the Backup
Fixed Disk command. There are several parameters that let you restore only
certain files.

To return files from a flexible to a hard disk, use the following steps:
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1. Choose the Restore Fixed Disk command from the DOS Utilities screen. A
dialog box appears:

Drive a contains the
backed-up files.

Restore Utility

Enter source and destination drive.

Parameters . . [ R: ci\..% /s [

{(J=Enter ) Esc=Cancel|] ( FizHelp )

Drive c is the
destination drive.

2. Type the drive letters for the source and destination drives.
3. Choose the ENTER area. You will see the following message:

Insert backup diskette in drive A:
Press any key to continue ...

4. Press any key to begin the restoration process. DOS Shell lists the files it is
restoring to the hard disk on your screen. After the restoration is finished,
you will see this message:

Press any key to continue ...

5. Press any key to return to the DOS Utilities screen. When the restoration
process is completed, the files you backed up return to the hard disk you
specified.

Returning to the Start Programs Screen

You can return to the Start Programs screen at any time. From the Start
Programs screen, you can move to and work with any other screen in DOS

Shell.

Using the keyboard, press (Esc). (To return to the Start Programs screen from
the File System screen, press (£3).)
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Using the mouse:

m To return to the Start Programs screen from the DOS Utilities and Change
Colors screens using the mouse, click the ESC=CANCEL area.

m To return to the Start Programs screen from the File System screen using the
mouse, click the ESC=CANCEL area.

Working With Your Directories

The File System screen contains all the commands that let you manage
directories. Just as you can choose commands to manage files, you can also
use commands on the File menu to manage directories. This makes it easy to
create new directories and rename or delete existing ones.
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To move to the File System screen, choose the File System command from the
Start Programs screen. The File System screen appears.

Directory identifier

Drive identifier Title bar Menu bar
File Options Arrange Exit Fi=Help
Ctrltletter selects a drive.

= =8
~C:\D0S
Directory Tree *
# b3
C:N\ t =APPEND .EXE 11,113 A5-14-88 } A
INDOWS =ASSIGN .coM 5,808 A5-14-88
EXCEL =ATTRIB .EXE 18,238 #5-14-88
7 HDos =IAUTOEXEC . BAT 92°  @o-18-88
ORD =/BACKUP .COM 33,759 85-14-88
ORKS E=BASIC  .COM 1,888 A5-14-88
=IBASICA .COM 36,285 #5-14-88
(=ICHKDSK .CoM 17,618 A5-14-88
=)COMMAND .COM 37,539 86-89-88
=ICOMP .CON 9,498 A5-14-88
FEMCONFIG  .SYS 148 86-09-88
F=BCOUNTRY .SYS 12,861 85-14-88
=DEBUG  .COM 21,613 #5-14-88
L (=IDISKCOMP .COM 9,912 #5-14-88
7] =DISKCOPY.COM 18,451 25-14-88 1Y
.| FEERDISPLAY .SYS 15,756 #5-14-88/ (¥
Flé=Actions Shift+F9=Command Prompt
Directory tree File list

Creating a Directory

A directory is like a file drawer you can store files in. Subdirectories can be
added to help organize your files, like dividers in the file drawer.

You must create a directory before you can put files into it:

1. Move to the File System screen.

2. Select the root directory (C:\ or A:\) at the top of the directory tree.
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3. Choose the Create directory command from the File menu. You’ll see a
dialog box.

[ Create Directory | |

New directory name. . :]

{J-Enter ) (Esc=Cancel ) (Fi=Help )

4. Type the name of the new directory in the text box. A name can be up to
eight characters long and you may add a three-character extension.

5. Choose the ENTER area. You’ll see the new directory as it appears on the
directory tree. You can add directories at any level in the tree.

Renaming a Directory
Follow these steps to change the name of a directory:

1. Choose the Deselect all command from the File menu if any files are
selected.

2. Select the directory you want to rename.
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3. Choose the Rename command from the File menu. A dialog box appears.

% 1
Renane Directory

Current name: TEST

Newmame. . [ ]

| <J=Enter | {Esc=Cancel | [Fi=Help )

4. Type the new name for the directory in the text box.

5. Choose the ENTER area. Your directory name changes in the directory
tree.

Deleting a Directory

To delete a directory, you must first delete the files and subdirectories
contained in the directory.

Follow these steps to delete a directory or a subdirectory:
1. Delete any files which may still be in the directory.
2. Select the directory.
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3. Choose the Delete command from the File menu. A dialog box appears.

1
lﬂﬂﬂ!ﬁlﬁﬁﬁﬂ!ﬂiﬁl

Directory: C:\TEST
Select an optiom.

1. Do not delete this directory

2. Delete this directory

[ (J=Enter ) [ Esc=Cancel | | F1=Help |

4. Type 2 to choose option 2 and delete the directory. Your directory is deleted
from the directory tree.

Copying a Directory

To copy a directory:

1. Select the disk drive or the directory to which you want to copy.
2. Create a new directory.

3. Select the directory you want to copy.

4

. Choose the Select all command from the File menu to select all the files in
the directory.
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5. Choose the Copy command on the File menu to copy the files. A dialog box
appears.

[ Copy File NN
From: | [LETTER.DOC =]
To: [N [+]

[ (J=Enter | | Esc=Cancel | [ Fi=Help |

6. Type the path of your new directory in the To: text box, including the drive
name if the directory is on a different drive.

7. Choose the ENTER area.

For example, suppose you have two files, JAN.INV and FEB.INV, that you
want to copy from the MONEY directory to the INVEST directory. When you
have filled in the Copy File dialog box, it should look like this:

| Copy File I
From: | [JAN.INU FEB.INV [+]
To: [ C:NINVEST] T+

{ ¢(J=Enter ) ( Esc=Cancel ) ( Fi=Help |
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If you want to duplicate a directory that has several subdirectories, create a
new directory first, then add the new subdirectories to it. Once the structure is
complete, you may then copy files from each of the source directories to each of
the new directories.

Canceling File Selections

After selecting one or all of your files, you can cancel your selection using the
Deselect all command from the File menu.

Working With Your Files

The File System screen contains all of the commands you need to work with
your files in hard and flexible disk directories. Working with the File System
screen, you can rename, copy, move, delete, and print your files. The File
System screen also lets you view the contents of files and the format of the files
as well. You can also view the contents of two directories at the same time to
compare contents.

Looking at Two Directory Lists at Once

When you first move to the File System screen, the files are in a single file list.
To see and compare the contents of two directories on two different drives, you
use the Multiple file list command.
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To see the contents of two directories, choose the Multiple file list command
from the Arrange menu. The screen now displays two directory trees and file
lists.

A7-18-88 File System

File Options Arrange Exit Fi=Help
Ctrl+letter selects a drive.

=0 =B

C:\DOS

Directory Tree * %

C:\ 1] 4
INDOWS l4| EDISKCOPY.COM 10,451 05-14-88 (A
EXCEL EHDISPLAY .SYS 15,756 @5-14-88

v |-D0S (=IDOSSHELL .BAT 216 86-09-88
ORD [Z| EEHDOSUTIL .MEU 9,768 06-89-89
ORKS 7] EE4DRIVER .SYS 5,289 95-14-68 ¥

=hn =38 (AC
Directory Tree * %
VAN LF] 4
1#:] =MNLSFUNC .EXE 6,878 @7-87-88 (&
E=4PC IBMDRU . MOS 263 @7-87-88
EZ%PCMSDRV . MOS 927 @7-87-88
%7l EEYPCMSPDRV.MOS 765 @7-87-88 ¥
-] =PRINT .COM 14,131 @7-67-88 |
F1@-Actions Shift+F9=Command Prompt

All of the File System screen commands and functions can be performed after
choosing the Multiple file list command. You can move around the screen using
the same methods you used with the single file list format, such as copying or
deleting files.

You can change either one of the directories to compare lists, and you can work
with multiple files. If you have chosen the Select across directories option, you
can work with multiple files in two directories. (The File options command
contains the Select across directories option. You choose the File options
command from the Options menu. For more information about the Select
across directories option, see the “Selecting Files Across Directories” section in
this chapter.)
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Looking at the System File List

The System file list shows you all the files in all of your directories plus a
summary list of system information.

To select your system file list, choose the System file list command from the
Arrange menu. The System file list appears.

Selected information
File information File list screen
2t File System
File Options Arrange |Exit Fi=Help
Ctrl+letter selects a drive.
=h =8 3C
C:\DOS
*
File 4
Name : DOSSHELL.BAT| |EEHCOUNTRY .SYS 12,861 ©5-14-88 8:00am (A
~ Attr 1 .. .a EEHCURT .CFG 59 87-12-88 4:51pn
Selected C A =ICVRT .EXE 31,795 82-16-87 3:48pn
Runber 1 a EZHCURT .PIF 369 @82-17-87 8:47an
Size 216 =DEBUG  .COM 21,613 85-14-88 8:88an
Directory I ISKCOMP .COM 9,912 85-14-88 8:80an
pd Name @ DOS V,;nglSKCOPY.COH 18,451 @5-14-88 8:88an
Size :© 1,116,973 EEHDISPLAY .SYS 15,756  ©5-14-88 8:0Ban
Files : 69 (=)DOSSHELL . BAT A6-A9-88 :H
Disk EEHDOSUTIL .MEU 9,768 86-89-89 3:18pn
Name @ JO =DOWN .EXE 9,342 086-30-88 9:48pn
Size . 10,932,224 EEHDRIVER  .SYS 5,289 @5-14-88 8:08am
fvail © 6,311,936 =JEDLIN  .COM 13,976 ©@5-14-88 8:08anm
Files : 216 EEHEGA .CPI 49,875 ©5-14-88 8:08am
Dirs 6 FFREXZNIUS . XFM 48,883 12-18-87 1:

=
[~~]
&
3
4= <]

F1B=fctions Shift+F 9:Command Prompt

Disk information
Directory information
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Using the System file list command, you can view all of your files regardless
of which directories they are in. The system file list provides the following
information:

Information Description

File File information provides the file name and type of file you
have selected. The attributes are: (a) archive, (r) read only,
and (h) hidden file. You assign these attributes with the
Change attribute command.

Selected Selected information provides the number of selected files on
the working disk and their combined total size. You may
see two columns, with the previously selected drive also
represented.

Directory Directory information provides the name, size, and number of
files in the directory you have selected.

Disk Disk information provides the name, size, amount of available
space, and the number of files and directories on the disk you
have selected.

Returning to a Single File List

After viewing your files and directories in different configurations and formats,

you can return to the standard single file list format to perform additional work
with your files.
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You can return to the single file list by choosing the Single file list command
from the Arrange menu. The single file list appears.

A mark appears next to the name of the active directory.
The directory tree shows your directories.

File Systen

File Options Arrange Exit
Ctrl+letter selects a drive.
=
C:\DOS
Directory Tree L
N B
N 5 =eerEd EXE 1,113 05-14-
INDOWS =RSSIGN .COM 5,808  B5-14-98
EXCEL =ATIRIB .EXE 18,238  #5-14-88
" 1-D0S SAUTOEXEC . BAT 32  #6-18-88
ORD EBACKUP  .COM 33,759  85-14-88
ORKS SBASIC  .COM 1,888  #5-14-88
=BASICA .COM 36,285  @5-14-
(=CHKDSK .COM 17,618  @5-14-88
[=)COMMAND .COM 37,539  @86-89-88
=coMp  .COM 9,498  05-14-88
EEBCONFIG  .SYS 149 96-99-88
EE™COUNTRY .SYS 12,861  #5-14-88
=DEBUG  .COM 21,613  @5-14-88
(=DISKCOMP .CON 9,912  05-14-88
7] =DISKCOPY.COM 16,451  65-14-98
| EADISPLAY .SYS 15,756  P5-14-88
F1B=Actions Shift+F9=Command Prompt
The file list displays the filenames stored in your active directory.

Changing the Order of Files on a List

Regardless of the format you are using, you can control the way files look on
the file list of the File System screen. With the Display options command, you
can limit the file display to files that have a common name or extension, or
reorder all files according to file name, file extension, creation date, file size, or
the order in which your files actually are stored on the disk.

To limit the files shown on a list or change their order, do the following:
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1. Choose the Display options command from the Options menu. A dialog box
appears.

MS-DOS Shell offers to sort
all of your files.

Display Options ‘
Name : E.*

Sort by:

@ Name
) Extension
1 Date
) Size
3 Disk order

{ (J=Enter ) [ Esc=Cancel ) [ Fi=Help )

You can sort files in a number of ways.

2. Type the file name or extension in the name text box. This limits the file
list display by name or extension.

3. Determine your sorting order by selecting one of the sort options.

4. Choose the ENTER area. The file list is reordered. If you are working with
a multiple file list, both lists will be reordered.

Getting Information About a File

Sometimes you may need details of a file when you are not using the System
file list command. You can get system information quickly by using the Show
information command.

To learn the details of a file, do the following:
1. Select the file you want information about.

2. Choose the Show information command from the Options menu. A dialog
box appears.
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Selected information
File information

Show Information

N
File

Name : AUTQEXEC.BAT

Attr ¢ .. .2
Selected C A

Number : 1 a

Size 24
Directory

r// Name  DOS
Size : 1,416,058

Files : 74
Disk
d Name : JO
Size 72,286,208
Avail : 60,867,840
Files : 614
Dirs 19

(Esc=Cancel | Fi=Help |

Disk information
Directory information

The Show Information dialog box provides the following information:

File information provides the file name and type of file you
have selected. The attributes are: (a) archive, (1) read only,
and (h) hidden file. You assign these attributes with the
Change attribute command.

Selected information provides the number of selected files on
the working disk and their combined total size. You may
see two columns, with the previously selected drive also

Information  Description
File
Selected

represented.
Directory

Directory information provides the name, size, and number of
files in the directory you have selected.
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Information  Description

Disk Disk information provides the name, size, amount of available
space, and the number of files and directories on the disk you
have selected.

Press or click the ESC=CANCEL area with the mouse when you’ve
finished viewing the Show Information box. You return to the File System
screen.

Selecting and Deselecting All Files

Most DOS Shell commands let you work with several files at once. The Select
all command from the File menu makes it easy to select every file on the file
list with one simple command. This saves time if, for example, you want to
copy or delete all of the files in a directory.

Follow these steps to select all of the files in a file list:
1. Select the directory in which you want to select files.

2. Choose the Select all command from the File menu. All your files are
selected.

To cancel the selection of a single file or all files in a file list, choose the
Deselect all command from the File menu. You can use the Deselect all
command even if you only have one or two files selected. It cancels any file
selections you have made.

Selecting Files Across Directories

Ordinarily, any file selections you may have made are automatically canceled
when you change directories. Using the Select across directories option, you
can select and work with files in more than one directory at a time. You

can select the Select across directories option by choosing the File options
command from the Options menu on the File System screen.

To work with files in multiple directories, follow these steps:
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1. Choose the File options command from the Options menu. A dialog box
appears.

—————
File Options
Confirm on delete

Confirm on replace
[0 Select across directories

((J=Enter ) { Esc=Cancel }{ Fi=Help |

2. Move to the Select across directories option.

3. Select the option. A mark appears beside the option to show that it is
selected.

4. Choose the ENTER area. The File System screen returns and you are now
ready to work with files in more than one directory.

The Select across directories option lets you work with files with the same
name (or different names) in every directory in which they reside. This is
useful when you want to view, copy, rename, or move files as a group.

Deleting files with the Select across directories option can be dangerous
because you may not want to delete all occurrences of a file.
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Note The File Options dialog box contains some important features

of DOS Shell.

# Two options, Confirm on delete and Confirm on replace, are
already selected when you install DOS Shell. The Confirm on
delete option presents you with a dialog box asking you to
confirm the deletion of a file or directory. The Confirm on
replace option presents you with a dialog box asking you to
confirm the replacement of a file or directory.

However, the Select across directories option is an option that
you choose to select after you install MS-DOS. Use all of these
options carefully.

To turn off the Select across directories option, follow these steps:

1. Choose the File options command from the Options menu.

2. Move to the Select across directories option in the dialog box.

3. Press the spacebar or click the option with the mouse. The mark which
appeared beside your file name when you chose Select across directories is
removed to show that the file is no longer selected.

4. Choose the ENTER area.

Renaming Files

Use the Rename command for changing the names of files. For example,

you have just created a letter to send to a client. You name the text file
LETTER.DOC. However, you must create additional letters, and the
LETTER.DOC file name does not help you remember which client you sent the
letter to. With the Rename command, you could rename the file with a more
appropriate name and organize your files more effectively.

Follow these steps to rename files:

1. Select the file or files you want to rename.
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2. Choose the Rename command from the File menu. A dialog box lists the
current name of the first file you selected.

Because MS-DOS Shell lets you rename
more than one file...

Re\\ame File

Current filename: LETTER.DQC 1 of 1

New filename. . :]

( (J=Enter ) [ Esc=Cancel )} [ F1=Help |

...this status line tells you which
file is currently being renamed.

3. Type the new file name in the New filename text box.

4. Choose the ENTER area.

If you selected more than one file, a dialog box appears asking you to rename
each of the files as they appear. When all of the files are renamed, you’ll return
to the File System screen.

Copying Files

You can copy a file and give it a new name or create a copy in a different
directory or on another disk using the Copy command.

Follow these steps to copy files:
1. Select the file or files you want to copy.
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2. Choose the Copy command from the File menu. A dialog box appears, with
the file names you selected in the From: text box.

Il Copy Filc I
From: [ [LETTER.DOC [»]
To: (_EZ \ F]

( (T =Enter ) [ Esc=Cancel | ( Fi=Help |

3. Type the path of the directory where you want to copy your files in the To:
text box.

4. Choose the ENTER area. The directory you specified now contains a copy
of your file.

Note You can’t copy files into your active directory unless you type a
i new file name. MS-DOS will not allow you to copy a file into a
t directory that contains a file with the same file name.

Moving Files

The Move command lets you move files from one location to another. You can
also rename a file during the process.

Follow these steps to move files:

1. Select the file or files you want to move.
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2. Choose the Move command from the File menu. A dialog box appears,
listing the file or files you selected.

N .- 71 I
From: [ LETTER.DOC =
o0 [J¢N B

(<J=-Enter | [Esc=Cancel | [Fi=Help |

3. Type the path of the directory where you want to move the file in the To:
text box.

4. Choose the ENTER area. The files you selected are now listed in the
directory you assigned them to, and are removed from their previous
directory.

You can change the name of a file by typing a new one at the end of the path.

Deleting Files

When you don’t need a file, you can delete it to make space for other files.
When you delete a file, you remove it permanently from the disk.

Follow these steps to remove files from a disk:

1. Select the file or files you want to delete.
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2. Choose the Delete command from the File menu. A dialog box lists the file
or files you selected.

Delete File

Delete . . ILETTER.DOC T=]

((J=Enter ) ( Esc=Cancel ) (Fi=Help )

3. Choose the ENTER area. A dialog box appears asking you to confirm your
actions.

4. Choose option 2 to delete the files. Your files are no longer on the disk.

Viewing the Contents of a File

The View command lets you see the contents of a file. When you first
choose the View command, your file appears in a form you can read—ASCII
(American Standard Code for Information Interchange). However, you can
choose to view your file in hexadecimal format, a binary format programmers
use.

You can view only one file at a time, and you may not change the contents of
the file.

To look at the contents of a file, follow these steps:

1. Select the file you want to view.

2. Choose the View command from the File menu. The file appears in the
ASCII format.

To change the format to hexadecimal, press (F9).

To return to the File System screen, press or click the ESC=CANCEL
area to return to the File System screen.
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Printing a File

If you have a printer connected to your computer, you can print as many as 10
files at a time with the Print command.

Here’s how to print files:
1. Select the file or files you want to print.
2. Choose the Print command from the File menu.

You’ll see a message that indicates your file or files are being printed.

Changing the Attributes of a File

The Change attribute command lets you control three features that help you
manage files:

m The hidden attribute causes your file to disappear from a directory list. For
example, when you use the Directory command at the MS-DOS command
prompt, you see a list of your files and programs. If there are any hidden files
in this list, they don’t appear. Your hidden files aren’t hidden from the file
list in the File System screen, however.

m The read-only attribute protects a file by preventing it from being changed.

m The archive attribute tells MS-DOS to make a backup copy of a file when
you use the Backup command. The file will not be backed up if you don’t
select this attribute.

You can change the attributes of a file by following these steps:
1. Select the file or files you want to change.

2. Choose the Change attribute command from the File menu. A dialog box
appears.

Change Attribute

1. Change selected files one at a time

2. Change all selected files at once

( <J=Enter ) ( Esc=Cancel | ( F1=Help |
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3. Select an option in the dialog box by typing 1 or 2. You may select the files
you want to change one at a time or all at once. The Change Attribute
dialog box appears, listing your choices.

Select this option if you want to protect
your file from being overwritten.

Select this option if you don't want the
file to display in a directory listing.

lﬂﬁﬁﬂﬂlﬂﬁ!ﬂﬂﬂﬂ!ﬁl

File: AUTOEXEC.BAT 1 of 1

To change attribute highlight item and
press Spacebar. Press Enter when complete.

~
I —
N3
Read only
//;/Archiue

( <J=Enter ) Esc=Cancel ) ( Fi=Help )

The file, AUTOEXEC.BAT, is an archived file.
This means the file is backed up whenever
you use the Backup command.

4. Move to the attribute you want to change or assign.

5. Select it by pressing the spacebar or clicking the mouse. A mark appears
next to the attribute to show that it is assigned. To remove a selection,
press the spacebar again and the arrow is removed.

6. Cheose the ENTER area.

There is an easy way to check whether an attribute has been assigned. Use
the Show information command for the file you are interested in. A selected
attribute will be indicated by a lowercase letter (h, r, and a) in the file.
Attributes are: hidden (h), read only (r), and archive (a).
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Starting a File

The Open command lets you start a program or file. You can only open files
with .COM, .EXE, or .BAT extensions and you can start only one program at
a time.

Here’s how to open a file:
1. Select the file you want to open.

2. Choose the Open command from the File menu.

I open Fil- I

Starting program: AUTOEXEC.BAT

Associated file !

Options. . [ [ [+]

(Esc=Cancel ) (FizHelp)

Type the special options your
program needs to run.

3. Type any sp}e%ialfc_o‘inmands your program needs to run in the Options text
box. Or, you can leave the text box empty.

4. Choose the ENTER area.

Associating Files With Programs

If you have a set of files that you often use with a particular program or
application, such as a letters file that you use with a word processing program,
you can save time with the Associate command. This command automatically
starts programs or applications whenever you open a file that has been
associated with the program or application.
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For example, all your word processing files end with the extension .DOC. You
usually edit the files using a program called EDITOR.COM.

Normally, you’d start EDITOR.COM, choose a file, and begin editing. But if
you associate the .DOC extension with the EDITOR.COM program, all you
need to do to edit any of your word processing files is to open the file. The
associated program, EDITOR.COM, starts when you open your document and
brings it to the screen for you to edit.

You could associate word processing documents with the extensions .DOC,
.TXT, or .LET with the same word processing program. However, an extension
can be associated with only one program at a time. For example, you couldn’t
associate the extensions .DOC, .TXT, or .LET with another program after you
had assigned them to a word processing program.

You can associate one program with 20 file extensions. Each time you open
a program, the corresponding files are available for you to access. When
you open a file which has been associated with a program, the program
automatically starts and you are ready to work with your files.

To associate files with the appropriate programs:
1. Select the program with which you wish to associate files.

2. Choose the Associate command from the File menu. The program you
selected is listed in the dialog box.

Type the extensions of the
filenames you wish to associate
with the program in the text box.

P Computer
ac, Museum

ﬁssoc iate File

Filename . .. AUTOEXEC.BAT 1 of 1

Extensions. . [ [ =]

[ <T=Enter ) [ Esc=Cancel ) ( Fi=Help )
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3. Type the file name extension (or extensions) that you want to associate with
the program you selected in the text box.

Note Don’t type a period at the beginning of the extension. To
i associate more than one extension with a program, type the
v extensions in the text box, with blank spaces between each one.

4. Choose the ENTER area. Another dialog box appears, asking you whether
you would like to be prompted for options.

5. Choose whether or not to prompt for options by typing 1 or 2. If you choose
to prompt for options, a dialog box appears when you open a file with one
of the extensions you specified. You can select any special parameters you
might need to run your program or application.

Note Prompting for options may not be necessary. Check the
manual for your program to learn if your program requires any
d additional options to start.

Now you can open a file and simultaneously open the program that works with
the file.

To disassociate a file extension from a program:
1. Select the program you want to disassociate from a file.

2. Choose the Associate command from the File menu. The first program you
selected is listed in the Associate File dialog box.

3. Erase the file extensions previously associated with the program you
selected.

4. Choose the ENTER area.

When you finish working with the File System screen, press {£3), or choose the
Exit File System command from the Exit menu.
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Working With Application Programs

You have great flexibility in managing the programs you work with frequently.
You can simply add the programs and applications to a group and then select
the program from the title list on the new group screen.

A group leads you to another screen where you’ll see a list of programs. You
can always recognize a group name because it has three small dots after its
name.

The Start Programs screen contains all of the commands that let you manage
programs.

When you add a program, application, or group to a group list, you can give
it any name you want. Starting a program then consists of selecting the name
from the group list and completing the command, using either your keyboard
or a mouse. The program starts right away. You don’t need to look through
directories or type complicated paths and file names.

The Main Group can include titles of
both programs and other groups.
File System is an application program.

Program Group Exit Fil=Help

Main Group
To complete the reorder, highlight the new
position, then press Enter. Press Esc to cancefl.

Command Prompt

Change Colors
L DOS Utilities...

F1B=Actions Shift+F9=Conmand Prompt

DOS Utilities is a group.
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Adding a Program

You can add programs to the Start Programs or DOS Utilities screens. The
title may represent an application, an individual program, or the title of a
group. You can add any program you like, write your own help text, and create
a password to limit access to the program.

To add a program to the Start Programs or DOS Utilities screens, follow these
steps:

1. Move to the screen where you want to add the program.

2. Choose the Add command from the Program menu. You’ll see the Add
Program dialog box on your screen.

Type the command that starts the
program in this text box.

Type the title of the program
in this text box.

Commands

Optional

Help text . . _f [ [+]
Passuo/

{Esc=Chncel )| F1=Help | [ F2=Save

if you want to limit access

to your program, type a

password in this text box.
Type help text in this text box.

3. Type the title you want to appear on the screen in the Title text box. Titles
may be 40 characters long, including blank spaces.

4. Move to the Commands text box.
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5. Type the same command string you would ordinarily type from the root
directory if you were starting the program there. When multiple commands
are required, press at the end of each command. For example, if you
usually type WORD to start Microsoft Word, type WORD here. But if the
Microsoft Word program is in a directory called MSWORD on drive C:, you
would type:

C: | |CD\MSWORD| |WORD

Note inserts the || marker that separates the parts of the
i command.

The three commands are explained in the following list:

This command Tells DOS Shell

C: to go to drive C:.
CD\MSWORD to change to the directory, MSWORD.
WORD to start the word processing program.

6. Move to the Help text box.
7. Type your help information.

Help information is optional. It appears when you press or click the
F1=HELP area. The help information you type appears on the screen
exactly as you type it (up to 478 characters), with uppercase and lowercase
letters and blank spaces. It’s automatically formatted to fit in the Help text
box unless you type an ampersand (&) to force a new line in the Help text
box.

8. Move to the Password text box and type in a password if you want one
applied to your program.

A password isn’t necessary to start a program. If you decide to assign a
password to a program, be sure to write it down and keep it in a safe place.
There is no way to find it once it has been typed, and you will need it in
order to use, change, or delete the program. It can include up to eight
characters, including blank spaces.
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9. Press to save your information. Your program title is added to the title
list.

Changing a Program

After you add a program title to a title list, you can change the name of
the program, the command that starts the program, any help text, or your
password.

Follow these steps to change a program:
1. Select the program on the title list.

2. Choose the Change command from the Program menu. If you assigned a
password to the program, the Password dialog box appears.

il Passuord I

Type password then press
Enter.

Password . . [::::::]

{{J=Enter ) [Esc=Cancel ] (FizHelp )

3. Type your password.
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4. Choose the ENTER area. The Change Program dialog box appears.

Type over existing text to change
your program litle.

Require

Title\f Jord Processing ]
Commands . . [ Jord [+]
Optional

Help text . . r l l»l
Password . . ::]

(Esc=Cancel ) (F1=Help ) (F2=Save )

Use the BACKSPACE or DELETE keys
to delete or edit text.

5. Type any new information into the text boxes.

6. Press to save your changes. Your changes are saved and you see the title
list again.

Note You can’t save your changes unless you’ve provided all the
required information: that is, filled in the Title and Commands
# text boxes.

Deleting a Program Title

You may delete a program, application, or title from any title list. Use the
Delete command from the Program menu on either the Start Programs or DOS
Utilities screens. Deleting a program name doesn’t delete the program from
your computer.

Follow these steps to delete a program from a title list:

1. Select the program title you want to delete.
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2. Choose the Delete command from the Program menu. If a password was
assigned when the program was added, the Password dialog box appears.

3. Type your password.
4. Choose the ENTER area. The Delete Item dialog box appears.

Delete Iten

1. Delete this iten
2. Do not delete this item

(¢ =Enter ) (Esc=Cancel ) ( F1=Help )

5. Select an option in the dialog box by typing 1 or 2. The program title
is removed from the title list but the program isn’t deleted from your
computer.

Copying a Program

You can copy a program to as many groups as you like. The title, the
command that starts the program, help text, and password, if any, are included
when you copy the program.

Follow these steps to copy a program from one screen to another:
1. Select the program title you want to copy.

2. Choose the Copy command from the Program menu. If a password was
assigned when the program was added, the Password dialog box appears.

3. Type your password.

4. Choose the ENTER area. The message at the top of your screen gives you
directions for the copy process:

To complete the copy, display the
destination group, then press F2.
Press F3 to cancel copy.

5. Move to the screen that contains the group you want to copy your program
to.

3-46 Using DOS Shell



6. Press to complete the process. The program is copied to the new group
and you can start it from either title list.

Starting a Program

To start a program using the keyboard, select the program title and press
(Enter)-

To start a program using the mouse, double-click the program name.

The program begins automatically. Exit the program as you would normally.
You will return to DOS Shell to resume your work.

Working With Groups

DOS Shell contains two groups when you install it: the Main Group and DOS
Utilities. You can add your own groups, each containing up to 16 programs.
For example, you can put similar programs into one group with a general
name, like Account. On your Account screen, you would add all the programs
you use to perform accounting functions, such as a program to maintain

your checkbook or estimate taxes. Or you might want to organize all of your
application programs into one group. You might also want to create a group
containing programs you want to guard with a password.

You can always recognize a group because there are three dots after the group
title.

Adding a Group to the Start Programs Screen

You can add a group only to the Main Group list on the Start Programs
screen. You may give a group any title you like and assign a password to limit
access to the group. You can also type help text when you create the new
group.

The Start Programs screen contains all of the commands that let you manage
groups.

Here’s how to add a group to the Main Group list:
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1. Move to the Main Group list on the Start Programs screen.

2. Choose the Add command from the Group menu. A dialog box appears.

Type the title of the group in this text box.

Type the name of the group
in this text box.

| add_Grovy I
Required /
Title . . [] 7
Filename . .
Optional
Help text . . [ ] \Lq\‘
Password
(Esc=Cancgl ) ( Fi=Help | F2=Save |

Type help text in this text box.

If you want to limit access to your group,
type a password in this text box.

3. Type the title for the new group in the Title text box.

Titles appear on the group list exactly as you type them in this text box.
Give your title no more than 37 characters, including blank spaces.

4. Move to the Filename text box.
5. Type a name for your new group.

Your file name can contain up to eight characters. Do not include an
extension. The file is automatically appended with the extension .MEU.

6. Move to the Help text box.

Help text is optional. If you want help information, type up to 478
characters, including blank spaces. Help text appears just as you type it,
with uppercase and lowercase letters and blank spaces. It’s automatically
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formatted to fit in the Help text box but, if you want to break a line to
begin a new paragraph, just type an ampersand (&) at the new line. Now
when you press (F1), you’ll see Help information for this group.

7. Move to the Password text box.

You can assign a password. It can include up to eight characters, including
blank spaces. If you don’t want to assign a password, leave this field blank.

8. Press to save your information. The group title is added to the group
list.

Note You can’t save your information unless you’ve provided all the
required information: that is, filled in the Title and Filename
ﬁ text boxes.

Changing a Group

After a group title is added to the Main Group list, you can change the title,
file name, password, or help text.

Follow these steps to change a group:
1. Select the group you wish to change from the title list.

2. Choose the Change command from the Group menu. If a password was
assigned when the group was added, the Password dialog box appears.

3. Type your password.
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4. Choose the ENTER area. The Change Group dialog box appears.

Type over existing text to change
your group title.

ll Change Grouy NS

Requﬁ\

Title . . . .} Jord Processing =]
Filename . . MORD ~ |

Optional -\

Help text . . [] =]

Password l::j

(Esc=Cancel | ( F1=Help ) { F2=Save )

Use the BACKSPACE or
DELETE keys to delete text.

5. Type the changes in the appropriate text box.
6. Press to save your changes. The Main Group screen appears.

Note You can’t save your changes unless you’ve provided all the
i required information: the Title and Filename text fields require
t information.

Deleting a Group

Deleting a group frees your screen of groups you no longer need. If you delete
a group, you delete all of the programs listed within it. Deleting a group from
the Start Programs screen doesn’t delete the programs from your computer.

To remove a group and all of the programs contained in it, follow these steps:
1. Select the group from the title list.

2. Choose the Delete command from the Group menu. If a password was
assigned when the group was added, the Password dialog box appears.
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3.

Type your password. A dialog box appears.

Delete Iten

1. Delete this item

2. Do not delete this item

‘(:]:Enterj Esc=Cancel | [ Fi=Help

. Choose option 1 to delete your group. The group is removed from the title

list. Any program titles you may have assigned to the group are deleted
when you delete the group. Those programs are not removed from your
computer, just from DOS Shell.

Reordering Group Titles

You can rearrange the order of program and group titles on the Start Programs
and DOS Utilities screens. You can also reorder the title list of a group you’ve
created.

Follow these steps to reposition a group or program title:

1.
2.

Select the title you want to reposition.

Choose the Reorder command from the Group menu. The message at the
top of your screen gives you directions for the reorder process.

To complete the reorder, highlight the
new position, then press Enter.
Press Esc to cancel.

. Move the selection cursor to where you want the title to move.

. Press (Enter). Your title is now repositioned on the list.
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Returning to the MS-DOS Prompt
There are several ways to exit DOS Shell and return to the MS-DOS prompt.

m Press until you return to the MS-DOS prompt. Choosing this method
lets you exit DOS Shell permanently.

m Choose the Command Prompt command from the Start Programs screen.
Choosing this method lets you leave DOS Shell temporarily.

m Press (shift)+(Fa). Choosing this method lets you leave DOS Shell

temporarily.

m With the mouse, click the SHIFT+FI=COMMAND PROMPT area.
Choosing this method lets you leave DOS Shell temporarily.

Returning to DOS Shell

If you’ve left DOS Shell temporarily, and you’re ready to return:

1. Type EXIT at the MS-DOS prompt.

2. Press (Enter). You'll return to the last screen you worked with.

If you’ve left DOS Shell permanently, and you’re ready to return:

1. Type DOSSHELL at the MS-DOS prompt.

2. Press (Enter). You'll start MS-DOS Shell, and see the Start Programs screen.
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A

Changing Your Setup Options

Once you install DOS Shell on your computer, you can view it and change

it according to your needs. The way DOS Shell works is determined by the
contents of the DOSSHELL.BAT file. This appendix describes the various
options that can be included in this file.

You can view the contents of the DOSSHELL.BAT file from the MS-DOS
prompt.

1. Type TYPE DOSSHELL.BAT

2. Press (Enter).

Your DOSSHELL.BAT file looks similar to the following display, depending on
the choices you made when installing DOS Shell:

Q@SHELLB DOSSHELL

QIF ERRORLEVEL 255 GOTO END

: COMMON

QSHELLC /TRAN/COLOR/DOS/MENU/MUL/SND/MEU:SHELL.MEU
/CLR:SHELL.CLR/PROMPT/MAINT/EXIT/SWAP/DATE

:END

Q@BREAK=0N

The text in the line that begins with @QSHELLC contains the options DOS
Shell uses as you work with it. You can change or eliminate any option at any

time. The following table describes the options and the effect they have on the
way DOS Shell works.

Caution Make a backup copy of your DOSSHELL.BAT file before you
# make any changes.
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... Option

/CLR:SHELL.CLR
/COLOR

/DATE
/DOS

JEXIT
/MAINT
/MENU

/MEU:SHELL.MEU

/MUL

/PROMPT

/SND

/SWAP
/TEXT

Description

tells DOS Shell to look in the SHELL.CLR file to set
up the colors for your monitor.

allows DOS Shell to change the colors on your screen
when you choose the Color Change command.

displays the date and time in the menu bar.

lets you move to the File System screen to work with
your files and directories.

lets you exit DOS Shell permanently. If you delete this
option, you will not be able to quit DOS Shell.

lets you maintain your programs and groups. If you
delete this option, you can’t edit a program or group.

lets DOS Shell create new screens when you create a
new group.

tells DOS Shell to look in the file SHELL.MEU for the
list of programs that make up the Main Group on the
Start Programs screen.

lets MS-DOS keep directory information in memory to
provide you with faster performance. If you delete this
option, MS-DOS must read the disk to provide you
with directory information.

lets you exit Shell temporarily and return to the
MS-DOS command prompt. If you delete this option,
the Command Prompt title on the Start Programs
screen will be inactive or grayed.

lets you take advantage of the sound function to
provide an audible warning during a Shell session.

lets MS-DOS swap directories to a flexible-disk drive.

makes DOS Shell appear in text mode. No graphic
images such as drive file icons will appear.
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Option Description

/TRAN clears DOS Shell from memory when you quit the
program. If you prefer to have Shell remain in memory
after you quit the program, edit the DOSSHELL.BAT
file and delete the /TRAN option.

Displaying MS-DOS Shell in Text or Graphics Mode

MS-DOS Shell can display screens in two ways: text and graphics. The
options for text and graphics are contained in the DOSSHELL.BAT file. The
/TEXT option displays MS-DOS Shell without graphic symbols such as file
and disk icons. The /CO options display high-resolution graphics. MS-DOS
Shell uses the highest resolution available on your computer. You can, however,
choose a lower resolution for your color monitor.

The following list describes your options:

Option Description

/TEXT DOS Shell appears in text mode.

/CO1 DOS Shell appears in 16-color, high-resolution 640 x
350 graphics.

/CO2 DOS Shell appears in 2-color, high-resolution 640 x

480 graphics (VGA and EGA modes). You must have
special hardware to support this option.

/CO3 DOS Shell appears in 16-color, high-resolution 640 x
480 graphics (VGA mode). You must have special
hardware to support this option.

Refer to your hardware manual to determine whether or not your computer will
work with any of these options.
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Using Mouse Options

If you have a mouse on your machine, you will find that working with DOS
Shell is easier. The following table describes the mouse options:

Option Description
J/LF provides for left-handed use of the mouse.
/MOS:PCIBMDRV.MOS lets DOS Shell work with an IBM mouse.

Note If you have a Microsoft Mouse (or any other mouse, except an
i IBM mouse), follow the instructions that came with your mouse
w to use it with DOS Shell.
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Customizing Your Applications

DOS Shell offers several features to make it more convenient to start and use
your application programs. You can create and display a custom dialog box
to prompt for a file name or program options before starting the program,
and you can carry out MS-DOS commands prior to starting the program or
immediately after exiting from it.

Displaying a Custom Dialog Box

When you create a custom dialog box for one of your application programs,
that dialog box is displayed for you to fill in the requested information each
time the program is started. For example, if you add a word processor to a
group, you can have DOS Shell automatically prompt you for the name of the
file to edit each time you start the word processor. You control the title and
prompt text for this dialog box and, to some extent, the information that can
be typed into the text box.

You create custom dialog boxes with the Add or Change command from the
Program menu. Whenever you add a program, you supply the commands
necessary to start the program in the Commands text box. To define a dialog
box, you type one or more startup options, enclosed in brackets, after those
commands.

For example, to start Microsoft Word with any of the startup options, you
would enter the following command line, with the desired options inside the
brackets:

C: | |ICD\MSWORD| [WORD [startup options]
The double vertical line (press (F4}) is used to separate commands, but it is not

used before the bracketed commands or between startup options. The startup
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options you can use to define a dialog box are described in the following list.
Combine the options you want for a particular dialog box within a single set of

brackets.
Option

[

/T“title name”

/1%instructions”
/P“prompt”

%on

/D“default”

/D“%n”
/R

/L“n”

/M“E”
/C“%n”

The maximum length of the command line is 500 characters.

Description

(no options inside the brackets) displays a dialog box with
standard instructions and prompts.

displays a dialog box that prompts for a file name or other
program input. The title name appears at the top of the
dialog box.

displays the instructions in the dialog box. You can enter
up to 40 characters of text.

displays the prompt next to the text box of your customized
dialog box. You can enter up to 20 characters.

defines the value entered in the dialog box as a variable with
the name n. You can define up to 10 variables for each
program.

displays the default value in the dialog box.
displays the value for the variable n as the default value.

clears the default value from the dialog box as soon as a key
is pressed.

limits the number of characters you can type into the dialog
box. Valid values for n are between 1 and 128.

lets you enter only existing file names in the dialog box.

saves the information defined as variable n to be used the
next time the program is started. For example, this could
be used to return automatically to the file you were last
editing.

Let’s look at a few sample command lines to see how these options work.
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Example 1

CD \WORD||WORD [/T"File Name"/I"Type name of file
to edit"/P"File name"]

With this command line, you can change to the WORD directory, start the
Microsoft Word program, and display a dialog box titled “File Name” with the
following instructions and prompt:

Type name of file to edit
Filename

Example 2

cd \WORD||WORD [/T"File Name"/I"Type name of file
to edit"/P"File name"/D"letter.doc"]

Like example 1, with this command line, you can start Word and display a
dialog box, but MS-DOS displays the file name LETTER.DOC as the default
value; that is, it will always bring LETTER.DOC to the screen.

Example 3

cd \WORD| IWORD [%1/T"File Name"/I"Type name of file
to edit"/P"File name"/C"%1"/D" ¥%1"/R]

With this command line, you start Word, display the dialog box prompting for
the file name, and store the entered file name as a variable. The next time you
start Word, that stored file name is displayed as the default value in the text
box. The /R at the end of the command line causes the default value to be
erased as soon as any key (except (Enter)) is pressed.

Using Additional Options

Other options are available to provide additional information to your program.
These options are typed at the end of the command line, outside of the
brackets used to display a dialog box. Press before entering the first option

and between each option. The available options are described in the following
list:
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Option
%n

/#

/@

Description

refers to the variable named n. Use this option in conjunction
with another command, such as Print.

substitutes the disk drive from which DOS Shell was started
for this symbol in the command line.

substitutes the path from which DOS Shell was started for
this symbol in the command line. Do not enter a backslash
character before this symbol.

Carrying Out MS-DOS Commands

You can use any MS-DOS command in the command line that you use for
starting your program. For example, in Chapter 3 you learned how to change
to another drive and select a directory. Include MS-DOS commands anywhere
in the command line, as long as they are outside the brackets used to define a
dialog box. Separate commands with a double vertical line by pressing (F4).

The following table shows some of the MS-DOS commands you might find

helpful:
Command

Print %n

Type %n

Pause

Description

This command prints the file referred to by the variable n. The
command line would look something like this:

WORD [%1/T"File Name"/I"Type name of file to edit"
/P"File name"]||print %1

This command displays the contents of the file referenced by
the variable n.

When you exit from the application program, the DOS Shell
Start Programs screen appears immediately. If any MS-DOS
messages are displayed as you exit from the program, they are
not visible. Use the Pause command in your command line

to stop before redisplaying the Start Programs. When you
exit from the program, the process will stop while you read
any displayed messages. Press any key when you are ready to
return to the Start Programs screen.

B-4 Customizing Your Applications



Using Batch Files

You may prefer to enter the commands necessary to set up and start your
application program in a batch file, especially if there are a lot of commands
required. You can then call that batch file from the command line and DOS
Shell will execute the commands in the batch file whenever you start the
program. (A batch file is an ASCII text file that contains a series of MS-DOS
commands, each on a separate line. All batch files have the extension .BAT.)

For example, suppose you have a batch file named WORD.BAT that contains
all the commands necessary to change directories and start Microsoft Word.
The batch file contents would be something like this:

C:
CD \WORD
WORD

To carry out this batch file whenever you start Word, you would enter the
following in the command line:

CALL WORD.BAT

You cannot include any options, including the bracketed commands to display
a dialog box, in the batch file. If you want to use these options, they must be
typed in the command line.
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Special characters
&, 3-43, 3-49
(] option, B-2

. , symbol of Group, 3-3
%n option, B-2, B-4
/@ option, B-4
/# option, B-4
/C“%n” option, B-2
/CLR:SHELL.CLR option, A-2
/CO1 option, A-3
/CO2 option, A-3
/CO3 option, A-3
/COLOR option, A-2
/D“%n” option, B-2
/D“default” option, B-2
/DATE option, A-2
/DOS option, A-2
J/EXIT option, A-2
/I“instructions” option, B-2
/L“n” option, B-2
/LF option, A-4
/M“E” option, B-2
/MENU option, A-2
/MEU:SHELL.MEU option, A-2

/MOS:PCIBMDRYV .MOS option, A-4

/MUL option, A-2

/P “prompt” option, B-2
/PROMPT option, A-2

/R option, B-2

/SND option, A-2

/SWAP option, A-2

/T “title name” option, B-2

/TEXT option, A-2
/TRAN option, A-3

A

Add command, 3-42, 3-48, B-1
Archive attribute, 3-36-37, 3-39
Arrow pointer, 1-7

ASCII format, 3-35

Assoclate command, 3-38-40
Attributes, 3-36

Backing up

definition, 3-7

fixed disk to floppy disks, 3-13-14
Backup Fixed Disk command, 3-13-14
Batch file, using to start programs, B-5
Brackets, used to define a dialog box, B-1,

B-2

Button, 1-12

c

Canceling a selection, 1-12, 2-14, 3-29
Change Attribute command, 3-36-37
Change Colors command, 2-24-25, 3-4-5
Change Colors screen, 1-5

Change command, 3-44-45, 3-49
Changing a directory name, 3-18-19
Changing a group, 3-49

Changing a program, 3-44-45

Changing directories, 2-4-5

Changing disk drives, 2-5
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Changing file attributes, 3-36-37
Changing screen colors, 2-24-25, 3-4-5
Checking a file attribute, 3-37
Chkdsk command, 2-23
Click, 1-13
Color options, A-2
Command Prompt command, 3-52
Commands
Add, 3-42-44, 3-48-49
Associate, 3-38-39
Backup Fixed Disk, 3-13-14
Change, 3-44-45, 3-49-50
Change Attribute, 3-36-37
Change Colors, 2-24-25, 3-4-5
Chkdsk, 2-23
: ‘Command Prompt, 3-52
- Copy, 2-10-12, 3-20-22, 3-32, 3-46
" Create Directory, 2-8-10, 3-18
Delete, 2-12-14, 3-20, 3-34, 3-45-46, 3-
50
Deselect All, 3-22, 3-29
Disk Compare, 3-11-13
Disk Copy, 3-10-11
Display options, 2-14-16, 3-26-27
DOS Utilities, 3-6-7
Exit File System, 3-40
File options, 3-23, 3-29-31
File System, 3-17
Format, 2-18-20, 3-8-9
Move, 3-33
Multiple file list, 3-22-23
Open, 3-38
Pause, B-4
Print, 3-36
Print %n, B-4
Rename, 3-19, 3-31-32
Reorder, 3-51
Restore Fixed Disk, 3-14-15
Select all, 3-29
Set Date and Time, 3-7-8
Show Information, 3-27-29, 3-37
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Single file list, 3-26
System file list, 3-24-25
Type %n, B-4
View, 2-7-8, 3-35
Comparing two flexible disks, 3-11-13
Copy command, 2-10-12, 3-20-22, 3-32,
3-46
Copying a disk, 3-10-11
Copying a file, 2-10-12, 3-32
Copying a program to a different group,
3-46
Create Directory command, 2-8-10, 3-17-
18
Creating a directory, 2-8-10, 3-17-18

D

Date
changing, 3-7-8
setting, 2-20-22
Delete command, 2-12-14, 3-20, 3-34, 3-
45-46, 3-50
Deleting a file, 2-12-14, 3-34
Deleting a group, 3-50
Deleting a program title from a group, 3-
45-46
Deselect All command, 3-22, 3-29
Dialog box, creating a custom, B-1, B-4
Direction keys, 1-11
Directories
changing, 2-4-5
copying, 3-20-22
creating, 2-8-10, 3-17-18
definition, 1-8, 3-17
deleting, 3-19-20
displaying two, 3-22
duplicating, 3-20-22
naming, 1-10
renaming, 3-18-19
Directory tree, 1-10
Disk Compare command, 3-11-13
Disk Copy command, 3-10-11



Disks

backing up, 3-13-14

comparing, 3-11-13

copying, 3-10-11

formatting, 2-18-20, 3-8
Displaying two directories, 3-22
Display options command, 2-14-16, 3-26—

27

DOSSHELL.BAT file, A-1
DOS Utilities command, 3-6-7
DOS Utilities group, 3-6
DOS Utilities screen, 1-5, 3-6
Double-click, 1-13
Drag, 1-13

E

Exit File System command, 3-15
Exiting MS-DOS Shell, 1-7, 2-26, 3-52
Exit Shell command, 1-7, 2-26
Extension option, 2-15-16

F

File Attributes, 3-36-37
File lists
changing the order of files on, 3-26-27
reordering, 3-26-27
system, 3-24-25
File options command, 3-23, 3-29-31
File order, 2-14-16
Files
associating with a program, 3-38-40
attributes, 3-36-37
copying, 3-32
deleting, 2-12-14, 3-34
deselecting, 3-29
disassociating from a program, 3-40
list of, 2-5, 3-24-27
moving, 3-33
printing, 3-36
renaming, 3-31-32
selecting, 2-6, 3-29-31

sorting, 2-14-16
viewing the contents of, 2-7-8, 3-35
File System command, 3-17
File System Program, 2-2-3
File System screen, 1-5, 2-3, 2-15, 3-2, 3-
22
returning to, 2-8

Formatting a disk, 2-18-20, 3-8-9

G

Graphics mode, A-3
Groups
adding, 3-47-49
changing, 3-49
definition of, 3-3

deleting, 3-50 Compyger
U

reordering, 3-51
symbol for, 3-3
titles, 3-47

H

Help, 2-3

creating, 3-43, 3-48
Hexadecimal format, 3-35
Hidden attribute, 3-36

K

Key definition line, 1-7

Keys, 1-10-12

L

Left-handed mouse option, A-4

M
Main Group, adding to, 3-47, 3-49
Menu bar, 1-7
Mouse
how to use, 1-13
options, A-4
scrolling with, 2-6
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Move command, 3-33 S

Moving files, 3-33 Screens, 1-5-7

MS-DOS prompt, 2-23, 3-52 Scroll bar, 2-3

MS-DO.S' Shell Scrolling, 2-3
definition of, 1-1 Select across directories option, 3-23, 3-
exiting, 1-7, 2-26 30-31
OptiQHS, A-1-4 . Select all command, 3-20, 3-29
requirements for using, 1-1 Select, definition of, 3-1

starting, 1-5—6

Selected information, 3-28
Multiple file list command, 3-22

Selecting your system file list, 3-26

Selection cursor, 1-7
0 moving with (F10), 1-11
Open command, 3-38 Set Date and Time command, 2-20-22, 3-
Opening a file, 3-38 7-8
Setting the date, 2-20, 3-7
p Setting the time, 2-20, 3-7
Password, 3-42-43, 3-49 Show Information command, 3-27-29, 3-
Pause command, B-4 37
Point, 1-13 Showing file information, 3-27
Print command, 3-36 Single File List command, 3-26
Printing a file, 3-36 Sorting files, 2-14
Print %n command, B-4 Starting a program, 2-2-3, 3-38, 3-47
Programs Starting MS-DOS Shell, 1-5, 2-2
adding to a group, 3-47-49 Start Programs screen, 1-5-7
starting, 2-2-3 System File List command, 3-24-25
Q T
Quitting MS-DOS Shell, 1-7, 2-26 Text mode, A-3
Time
R changing, 3-7-8
Read-Only attribute, 3-37 setting, 2-20-22
Removing directories, 3-19 Title bar, 1-7
Removing files, 3-34 Title list, 1-7
Rename command, 3-19, 3-31-32 Type %n command, B-4
Renaming files, 3-31-32
Reorder command, 3-51 v
Reordering group titles, 3-51 View command, 2-7-8, 3-35
Restore Fixed Disk command, 3-14-15 Viewing files, 2-4, 2-6-8, 3-35
Restoring files, 3-14-15
w

Wildcards, 2-16
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